1. nadventr's Avatar
    I switched be BB Classic from Verizon to T-mobile last week and no matter what I do, I can't get any data. Voice and texting is fine and Wifi calling/data works. T-mobile tech support told me that there is nothing they can do, that something needs to be reconfigured by Blackberry.

    I have set the proper APN and my phone is picking up Tmobile LTE, but it says "voice only".

    Any one experience this before or have a solution?

    Thank you,

    Sean
    05-23-17 02:03 AM
  2. eiruvrav's Avatar
    I know this may sound silly but did you check to make sure that data is turned on in your settings if it's not on or set to not allow while roaming you will have voice only.
    05-23-17 03:35 AM
  3. vladi's Avatar
    Due to nature of Verizon Q10 device not all bands are compatible with other carriers in US or around the world . In other words there is no reason to use CDMA network in 2017 or its devices.

    Your best bet is to trun on 3G and 2G data in settings and depending on your location you might get 1900 UMTS band on T-mobile instead of usual 1700/2100 unique only to T-mobile in the whole world. You will not be able to get 4G anywhere on Verizon Q10 other than Verizon or maybe Sprint.

    US is a mess when it comes to radio frequencies and thus you have this problem.
    05-23-17 04:07 AM
  4. igotberryfever's Avatar
    You need to change you APN settings from verizon to Tmobile. You phone will work with no problems
    BBM me if you have questions 2C35DEA1

    Posted via CB10
    05-23-17 05:43 AM

Similar Threads

  1. Replies: 3
    Last Post: 05-25-17, 05:19 PM
  2. Do I add my accounts through phone setup or through hub?
    By hoopitz in forum BlackBerry KEYone Support
    Replies: 7
    Last Post: 05-23-17, 01:34 PM
  3. Why blackberry passport can not received emails from active-sync?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 05-23-17, 04:45 AM
  4. How To Fix 200 Reset error?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 05-23-17, 03:48 AM
  5. Transferring Notes from DETEK60 to KEYone
    By Jonathan Rodden in forum Ask a Question
    Replies: 1
    Last Post: 05-23-17, 01:31 AM
LINK TO POST COPIED TO CLIPBOARD