1. carloeh's Avatar
    Is anyone else experiencing poor battery life and phone heating while using Spotify in 10.3.3? I noticed it when I updated to 10.3.3.2049 from 10.3.2.2474 on my PPSE. I was hoping it would be resolved in 2163 but it hasn't. Both my 10.3.3's were loaded OTA.

    Device Monitor shows Spotify using up to 5+% of battery while using Spotify with Bluetooth. It only used .5-.6% on 10.3.2.

    Anyone know a version of Spotify that plays well with 10.3.3? Thanks.
    12-18-16 10:26 PM
  2. Rad_Book's Avatar
    I was after I updated from google play, so I uninstalled and downloaded the apk direct from the spotify website and all is back to normal.

    Posted via CB10
    12-18-16 10:35 PM
  3. carloeh's Avatar
    Thanks will give that a try and update this thread. I've been running Spotify for the last couple hours and I'm now consuming 8.8% of battery.

    Posted via CB10
    12-18-16 10:53 PM
  4. carloeh's Avatar
    Holy crap I don't know how you figured that out but the app from the Spotify website fixed all my problems. Thanks!

    Posted via CB10
    Rad_Book likes this.
    12-19-16 08:45 PM
  5. chern's Avatar
    Spotify app performance on 10.3.3-img_20161219_210631.png

    I have the latest Spotify app via amazon apps on my Passport 10.3.3.2163 and have both problems, bad batter life and overheating.

    when closing the app, it still drains the battery. I have close through device manager.

    Posted via CB10
    12-19-16 09:08 PM
  6. carloeh's Avatar
    Try downloading the app directly from the spotify website as suggested above. Put my phone back to its prior state.

    Posted via CB10
    12-19-16 11:42 PM

Similar Threads

  1. Blackberry Link and Windows 10
    By Dok Kang in forum BlackBerry Z10
    Replies: 21
    Last Post: 02-25-17, 07:30 AM
  2. Replies: 4
    Last Post: 02-14-17, 06:19 AM
  3. Anyone know how to get uber application to work on Blackberry classic Q10
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 12-18-16, 06:53 PM
  4. Problem with BlackBerry Hub after 10 OS 10.3.3.1435 update
    By avidoje in forum BlackBerry Passport
    Replies: 1
    Last Post: 12-18-16, 05:16 PM
  5. Need help with youtube app playing video please
    By Feridun Ahmedov in forum Ask a Question
    Replies: 4
    Last Post: 12-18-16, 02:17 PM
LINK TO POST COPIED TO CLIPBOARD