1. CrackBerry Question's Avatar
    I've got my keyone few weeks ago. It worked perfectly fine with my sim (from CSL) in Hong Kong. However, after using another sim during my trip to Singapore last week, my original sim stopped working.

    I've been to the service provider to get a new sim but it didn't work either. I've tried several times re-inserting the sim. Still no luck.

    Every time I insert my sim, it shows "No Service" on the top but other sim cards work fine (e.g. the one I got from Singapore). The phone is not able to search for Available Network either.

    Any ideas how I could fix it? I have been dealing with this for a few days already.

    Thank you so much in advance!
    06-15-17 10:12 AM
  2. BB-JAM215's Avatar
    Does the SIM card tray slide in an out without any problems?

    Are you sure the SIM card is not in the place for the SD card?
    06-15-17 11:59 AM
  3. 311y's Avatar
    i`m facing simmilar issue with blackberry z10 and yeah i know how the place for sd card and sim card look like
    06-18-17 04:24 AM

Similar Threads

  1. Using keyboard apps on keyone
    By JL009 in forum BlackBerry KEYone
    Replies: 3
    Last Post: 06-15-17, 10:47 AM
  2. Pin Entry on Restart Makes me wait?
    By jermainewill in forum BlackBerry DTEK60
    Replies: 1
    Last Post: 06-15-17, 10:08 AM
  3. SD Card Unexpectedly Unexpectedly Removed
    By Harry73127 in forum Ask a Question
    Replies: 2
    Last Post: 06-15-17, 08:54 AM
  4. Amazon shipping Keyone
    By dubbsix in forum BlackBerry KEYone
    Replies: 1
    Last Post: 06-15-17, 08:06 AM
  5. Please tell me. How to stop / on micro phone on blackberryz10?
    By vamsidhar somavarapu in forum BlackBerry Z10
    Replies: 2
    Last Post: 06-15-17, 02:04 AM
LINK TO POST COPIED TO CLIPBOARD