1. maryahshdid's Avatar
    I don't know why my BlackBerry Z30 is having this display issue. When I turn the phone off and start charging it, the display normally shows a thunderbolt but mine is blinking constantly in low light and it does not happen only when it's off charging but when the screen turns off it blinks white (when it locks and unlocks the screen). I don't know if it might be because got an 8GB SD Card on it but I don't think so as I got it three months ago... By the way, I haven't upgrade the software cause I did but didn't like it, so I had to format my phone to go back to the original one which is the 10.2.1.3062 I will really appreciate if you could help me with this issue with my phone.*

    It does work well other than this issue. What I did was that when I upgrade it to the 10.3.1 (I'm pretty sure it was a latest version than that but really don't remember it) I had to do it using another Sim Card as my carrier wasn't supporting yet the new software and when it did that, I didn't like it at all. The battery life was less than useless (it went from 100% to 20% in about 5 or 6 hours when it normally does in 15 o 16 hours), the phone got really hot in hand when you were using it, and when I wanted to do a back up of it and connected it to the pc, it never did. It always said that there wasn't a successful connection between the pc and the phone and that I needed to check the cable, when actually it was working properly, so I just reverted it by typing wrongly my password 10 times and writing "blackberry" on it and that was it. All back to normal. Had my 10.2.1.3062 back. Besides this, I remember that I stood up a whole night while it loaded the new upgrade, and I fell asleep and it kept working on it.* After that, it started to work perfectly again and my carrier still didn't have the upgrade yet. Now, they do but it isn't the 10.3.2 (which I think was the one I had when I manually upgrade it with the other carrier Sim Card) but the 10.3.1.1784 Still don't want to upgrade my phone yet, as for example, my dad did with his Q10 and his phone battery life isn't the same had before and, I*still*don't know why, it's phone main volume works just at a 50% even if you move the line up to the 100%. Don't know what's the deal with this OS version but it isn't working very well on this two phones.

    Thank you.

    Posted via CB10
    08-14-15 08:07 PM
  2. anon(9208252)'s Avatar
    Try a hard reset, by holding the volume up and down buttons in for a while until you see the blue loading circle. Maybe it's looping and just needs to be reset.
    08-14-15 08:47 PM
  3. dreamz_gaurav's Avatar
    Could you let me know if this worked?

    Posted using Z30 | 10.3.2.2339
    08-14-15 10:20 PM
  4. maryahshdid's Avatar
    Could you let me know if this worked?

    Posted using Z30 | 10.3.2.2339
    Hi, dreamz_gaurav
    I did what you suggest but unfortunately it still didn't work, completely.
    Meaning, it stopped blinking when I lock and unlock the screen but when it's off charging, the thunderbolt is blinking like if it's going to switch absolutely off.

    Thanks for your suggestion. I'm still open for more ideas.

    Maryah Shdid.
    08-14-15 11:18 PM
  5. maryahshdid's Avatar
    Try a hard reset, by holding the volume up and down buttons in for a while until you see the blue loading circle. Maybe it's looping and just needs to be reset.
    I did what you suggested yesterday and it stopped happening when I locked and unlocked the phone but not when it was charging off. But today, when I unlocked it, it happen again. I thought it got fixed a bit but no, it didn't work how I expected.

    Still open for more ideas.
    Thank you.

    Maryah Shdid.
    08-15-15 07:55 AM
  6. anon(9208252)'s Avatar
    I would think you might have to reload your OS.
    08-15-15 09:21 AM
  7. maryahshdid's Avatar
    I would think you might have to reload your OS.
    You mean I should reload my OS or the new one?

    Maryah Shdid.
    08-15-15 09:47 AM
  8. anon(9208252)'s Avatar
    I would probably load the new 2339 leaked OS, it seems to be running very well.
    08-15-15 09:50 AM
  9. maryahshdid's Avatar
    I would probably load the new 2339 leaked OS, it seems to be running very well.
    The problem is that my carrier only has the 10.3.1 working and the other one with which I did it manually with another Sim Card has the 10.3.2 but none of those had work with my phone how they must do.
    Do you think ot might be a display problem because of the different times my phone has dropped? Not that many, but it has.

    Thank you.

    Maryah Shdid.
    08-15-15 09:54 AM
  10. anon(9208252)'s Avatar
    The problem is that my carrier only has the 10.3.1 working and the other one with which I did it manually with another Sim Card has the 10.3.2 but none of those had work with my phone how they must do.
    Do you think ot might be a display problem because of the different times my phone has dropped? Not that many, but it has.

    Thank you.

    Maryah Shdid.
    yes it might be, send it back to get fixed.
    08-15-15 09:56 AM

Similar Threads

  1. Replies: 10
    Last Post: 08-15-15, 05:54 PM
  2. Panning across Z30 Panorama images
    By F2 in forum BlackBerry Z30
    Replies: 4
    Last Post: 08-15-15, 01:20 PM
  3. Replies: 3
    Last Post: 08-15-15, 09:10 AM
  4. Why won't my Z10 finish OS updates?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 1
    Last Post: 08-15-15, 06:59 AM
  5. Security wiped my BB10 last night at 10pm and its 8pm the next day. at 98 . What can I do?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 08-14-15, 07:05 PM
LINK TO POST COPIED TO CLIPBOARD