1. BBrickk's Avatar
    Hi guys,
    So as the title says it, a friend of mine is getting what I call the red light of death. while the device is completely off, I power it on and the led turns on for a few seconds the turns off. When I give it a second try to boot it up, this time the led stays on for a longer period (30-60 seconds maybe).
    Screen stays black in both scenarios.
    He doesn't know the reason. All he knows it was sudden. He didn't use his phone outside the norm (no leaks, no android apps/sideloads, running latest official os).
    He tired hard reset from Link and from the device.
    11-09-14 06:55 AM
  2. menshawy's Avatar
    Take out the battery for 15 minutes or so.. prepare Link.. hook the phone to PC and go to Reload OS.. insert battery

    Posted via CB10
    11-09-14 07:28 AM
  3. archieAPC Z10's Avatar
    Take out the battery for 15 minutes or so.. prepare Link.. hook the phone to PC and go to Reload OS.. insert battery

    Posted via CB10
    That's right. Pulling out the battery is normal in blackberry even before...during the time were there are no touch screen phones yet...it's a practice already.

    APC via Z10
    11-09-14 07:50 AM
  4. menshawy's Avatar
    That's right. Pulling out the battery is normal in blackberry even before...during the time were there are no touch screen phones yet...it's a practice already.

    APC via Z10
    How simple is that! Genius actually

    Posted via CB10
    archieAPC Z10 likes this.
    11-09-14 12:21 PM
  5. BBrickk's Avatar
    Take out the battery for 15 minutes or so.. prepare Link.. hook the phone to PC and go to Reload OS.. insert battery

    Posted via CB10
    Do I insert the battery before pressing reload OS?
    11-10-14 05:49 AM
  6. BBrickk's Avatar
    okay so unfortunately this method is not working.
    1) Without any wiring connected to the phone, when turning it on, the Led stays on for almost 2-3 minutes with nothing happening on the screen (screen isnt even on)
    2) When trying to connect it with a usb to Link, the pc doesnt even see it. No drivers, no sign of Link seeing it, just the same Led on for 2-3 minutes.
    11-10-14 06:35 AM
  7. benbraun322's Avatar
    okay so unfortunately this method is not working.
    1) Without any wiring connected to the phone, when turning it on, the Led stays on for almost 2-3 minutes with nothing happening on the screen (screen isnt even on)
    2) When trying to connect it with a usb to Link, the pc doesnt even see it. No drivers, no sign of Link seeing it, just the same Led on for 2-3 minutes.
    Try letting the phone sit for a few hours.
    Then plug it in and just leave it for like 5 hours.
    Try holding down the power and both volume buttons st the same time for like 30 seconds.

    Good Luck

    Posted via CB10
    11-10-14 06:40 AM
  8. BBrickk's Avatar
    How is this going to help? I feel like the OS isnt even responding because not even the PC or Link sees the device.

    Try letting the phone sit for a few hours.
    Then plug it in and just leave it for like 5 hours.
    Try holding down the power and both volume buttons st the same time for like 30 seconds.

    Good Luck

    Posted via CB10
    11-10-14 08:16 AM
  9. benbraun322's Avatar
    How is this going to help? I feel like the OS isnt even responding because not even the PC or Link sees the device.
    OS isn't responding because it isn't on, this might help it boot up

    Posted via CB10
    11-10-14 09:02 AM
  10. BBrickk's Avatar
    OS isn't responding because it isn't on, this might help it boot up

    Posted via CB10
    Do you mean plug it into the pc and wait for it to be recognised or plug it into the power outlet?
    The problem is, the led doesn't stay on. It does for a few minutes then it shuts off. So how would it revive itself if it is not even on during the 5 hours?
    11-10-14 10:14 AM
  11. benbraun322's Avatar
    Do you mean plug it into the pc and wait for it to be recognised or plug it into the power outlet?
    The problem is, the led doesn't stay on. It does for a few minutes then it shuts off. So how would it revive itself if it is not even on during the 5 hours?
    Well the reason your doing this is to make sure the battery is charged and holding down the power button along with the volume buttons for 30 seconds usually forces the device to boot.

    Posted via CB10
    11-10-14 11:21 AM
  12. BBrickk's Avatar
    Well the reason your doing this is to make sure the battery is charged and holding down the power button along with the volume buttons for 30 seconds usually forces the device to boot.

    Posted via CB10
    I have already confirmed that the battery is charged by using it on my own z10. It's not a battery issue here. It's beyond that.
    It's an Stl100-3 and the volume up\down arent doing anything, only the power button does something: With the LED on (solid), I press and hold the power button for 10 seconds, the LED turns off for a second and it comes back on (solid).
    Last edited by BBrickk; 11-10-14 at 12:54 PM.
    11-10-14 11:56 AM
  13. benbraun322's Avatar
    Sorry then,
    Have you tried volume keys and power button at the same time, some people have had luck with that...

    Posted via CB10
    11-10-14 12:16 PM
  14. BBrickk's Avatar
    Sorry then,
    Have you tried volume keys and power button at the same time, some people have had luck with that...

    Posted via CB10
    Yeah these don't even work. I could really use a more practical solution.

    Main issue right now is my pc isn't seeing the phone. I've tried all USB ports, different wires, with/without battery. Still nothing.
    11-11-14 12:26 AM
  15. vutranloc's Avatar
    Your device flash chip is toasted. I'm sorry but you can do nothing but bring it to where you bought it and demand warranty

    Posted via CB10
    11-11-14 01:11 AM
  16. benbraun322's Avatar
    What I don't understand is what was your friend doing when this happened to his Z10?

    He obviously did something he's not telling you about... this stuff doesn't just happen.

    Posted via CB10
    11-11-14 02:21 AM
  17. BBrickk's Avatar
    Okay so after trying all of the suggestions on here, nothing seems to bring it back to life. The pc refuses to see the device. Looks like the device is toast.
    Thank you for your effort guys, much appreciated.
    11-12-14 02:38 AM
  18. kbz1960's Avatar
    This just happened to my Z30 today. I felt it vibrate, wasn't able to check it right away, when I did it was showing a dead battery and then went blank. Plugged it in for an hour, the red light came on then changed to a blinking amber light. Turn it on and nothing. The computer does recognize it. I installed an autoloader and the same thing. Trying a reload from link now.
    11-12-14 04:16 PM
  19. kbz1960's Avatar
    Turned out to be the screen. Glad I had the old one still.
    11-12-14 07:09 PM
  20. benbraun322's Avatar
    Screen just died?
    You should hook it up through HDMI to make sure it works before you replace it...

    Posted via CB10
    11-12-14 11:39 PM
  21. kbz1960's Avatar
    Screen just died?
    You should hook it up through HDMI to make sure it works before you replace it...

    Posted via CB10
    Might had been a good idea. It was a screen I bought a couple months ago to replace mine that is cracked only in the top left corner. I put that screen back on and it works.
    11-13-14 06:40 AM

Similar Threads

  1. How does out-of-the-box security work?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-11-14, 06:02 PM
  2. Replies: 25
    Last Post: 11-09-14, 10:07 PM
  3. Contacts on the Z10
    By hopper76 in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 11-09-14, 11:06 AM
  4. Replies: 1
    Last Post: 11-09-14, 07:15 AM
  5. Will have a chance to use my Z10 for work
    By wyleybuster in forum BlackBerry Z10
    Replies: 2
    Last Post: 11-09-14, 06:16 AM
LINK TO POST COPIED TO CLIPBOARD