1. jaynas94's Avatar
    Hello everyone ok I just got a Q10 from someone so far the device is cool not brand new though but I can manage, my issue is the usb port charges the phone quite alright, but it never shows up on my pc whenever I connect it. I have tried turning on everything I could turn on but still no results... pls what do I do

    Posted via CB10
    07-13-15 09:02 AM
  2. jafobabe's Avatar
    07-13-15 09:15 AM
  3. Benjamin Evald's Avatar
    Have you tried another usb cable? Maybe the TX and RX wires on the cable are broken...

    Posted via CB10
    07-13-15 10:54 AM
  4. Nicholas Recker's Avatar
    Make sure the usb cable that your using can be used for data and not just charging. also make sure you have link installed on your computer

    Posted via CB10
    07-13-15 11:32 AM
  5. jaynas94's Avatar
    Make sure the usb cable that your using can be used for data and not just charging. also make sure you have link installed on your computer

    Posted via CB10
    Yeah I did all. That still not working

    Posted via CB10
    07-13-15 11:48 AM
  6. jaynas94's Avatar
    [QUOTE=jafobabe;11786691]Make sure you have Link installed on your PC....


    Yeah I do have it, no show


    Posted via CB10
    07-13-15 11:49 AM
  7. Nicholas Recker's Avatar
    Have you tried a different computer.

    If you don't have access to one, delete the drivers and all blackberry software on the one you are using. Then try again

    Posted via CB10
    07-15-15 05:02 PM

Similar Threads

  1. Blue highlight always on
    By jackstar86 in forum BlackBerry Classic
    Replies: 8
    Last Post: 07-15-15, 05:25 PM
  2. Wow, DT issue on the Classic disappeared...
    By johnnydoesai in forum BlackBerry Classic
    Replies: 6
    Last Post: 07-15-15, 02:49 AM
  3. Q10 saved!
    By stavwoz in forum BlackBerry Q10
    Replies: 12
    Last Post: 07-14-15, 01:16 PM
  4. Q10 running hot from using Waze Amazon App.
    By Prem QNX in forum BlackBerry Q10
    Replies: 2
    Last Post: 07-13-15, 01:37 PM
  5. Replies: 1
    Last Post: 07-13-15, 08:43 AM
LINK TO POST COPIED TO CLIPBOARD