1. CrackBerry Question's Avatar
    Hello sir, can i have some questions about my blackberry z10? Yesterday, I downloaded the BB OS 10.3.1 after i download it on my phone. I click the setting button then it did not pop up on my mobile screen. Then i restart my mobile. after a few minutes, there is a loading screen in my mobile. it only took and stock up in 100% below that there is a reminder that " Finalizing device setup" I wait 10hrs. But nothing changes. I restart again my phone, Same sequence again. What should i do? What is that problem of my phone?
    02-28-15 09:04 PM
  2. diegonei's Avatar
    First of all, charge it pronto! You don't want the battery to die during boot! Let it feed for 20 minutes of so at least.

    After that, try holding the top buttom till the device reboots. It should clear whatever is stuck.

    If that fails, this is the one time a battery pull is advised. Take it out, wait a minute, put it back in.

    IF that STILL fails, plug to link and let it refresh the OS (and I hope you have a backup).

    Best of luck!
    02-28-15 09:11 PM
  3. xymyr23's Avatar
    Hi! Have the same problem. Tried the buttons options but no go. When I connected my phone to the computer, it won't recognize the device.will the BlackBerry link option still work? Thanks


    Posted via CB10
    03-02-15 12:12 PM

Similar Threads

  1. Replies: 2
    Last Post: 03-15-15, 12:50 PM
  2. Vintage BlackBerry Devotee
    By H0iP0ll0i in forum BlackBerry Classic
    Replies: 5
    Last Post: 03-01-15, 11:12 AM
  3. BlackBerry z30 gmail
    By naorrazla in forum Ask a Question
    Replies: 4
    Last Post: 02-28-15, 11:06 PM
  4. I dont see a kindle app in BlackBerry
    By Judyam in forum Ask a Question
    Replies: 5
    Last Post: 02-28-15, 10:58 PM
  5. "Send" button is blurred! Quick help!!
    By AnhPham in forum BlackBerry Q10
    Replies: 4
    Last Post: 02-28-15, 08:57 PM
LINK TO POST COPIED TO CLIPBOARD