1. CrackBerry Question's Avatar
    Put it to charge yesterday and woke up to find it turned off.

    Pressing the power button with the charger plugged in flashes the LED light red twice, the screen lights up (nothing on the display, just the backlight turns on) for 3 seconds, and the process keeps repeating itself.

    On trying to connect to the PC, the PC makes a 'new USB connection found' sound, the red LED blinks twice, the backlight comes up, the PC makes 'USB disconnected' sound, and the process keeps repeating itself over and over.

    Already tried:
    1. Removing the battery connection and doing the battery reset
    2. Trying a hard reset
    09-25-17 04:09 AM
  2. Dunt Dunt Dunt's Avatar
    Can try an Autoloader >>>>https://forums.crackberry.com/bb10-l...rchive-943672/

    Maybe that will get the device working again, but you data on the internal memory is gone. If you encrypted the SD Card, that too will be gone.

    It's not all that unusual of a thing to happen with BB10.... did it twice in three years on my Z10.
    09-25-17 09:34 AM

Similar Threads

  1. Replies: 2
    Last Post: 09-25-17, 09:34 AM
  2. Can the power button on the Priv be replaced?
    By Debraj Biswal in forum Ask a Question
    Replies: 1
    Last Post: 09-25-17, 01:17 AM
  3. BlackBerry Priv not showing the red asterick in top corner
    By terileaevans in forum BlackBerry Priv
    Replies: 1
    Last Post: 09-24-17, 10:39 PM
  4. Lag after update to AA472 on Rogers
    By maranr in forum BlackBerry KEYone
    Replies: 0
    Last Post: 09-24-17, 10:22 PM
LINK TO POST COPIED TO CLIPBOARD