1. alanrt's Avatar
    I didn't use my Playbook for 9 months. A week ago I wanted to use an app on it. I booted the Playbook up and the battery was showing 6% charge. I now know I should have switched it off and charged it but I used it until the battery died. I thought if the battery was still holding charge it was ok.

    The battery will no longer charge. I have so far spent a total of 6 or 7 hours over 3 nights trying to stack charge it without success. I also tried a factory reset while plugged into my PC. On the rare occasion when it starts up while connected to either my original charger or my rapid charging dock I either get an error message saying that the reset cannot continue until the battery reaches 20%.

    When left on the charging dock it sometimes attempts to start itself. I get the boot up screen for 20 seconds or so and then I get either a screen saying I should charge the battery or the battery charging symbol and then it switches off again.

    Should I replace the battery or is there anything else I can try?
    07-26-14 08:20 AM
  2. darylsuds's Avatar
    This has happened to me as well. I left mine on charge for about 3 days and it worked. Good luck

    Posted via CB10
    07-26-14 08:44 AM

Similar Threads

  1. Which runtime do I need for 10.2.1.2977
    By spinderellax7 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 07-26-14, 11:25 AM
  2. Offical 10.3 when launching for z10
    By ujjal singh in forum Ask a Question
    Replies: 5
    Last Post: 07-26-14, 06:45 AM
LINK TO POST COPIED TO CLIPBOARD