1. giftsonbb's Avatar
    Update:
    I upgraded the OS version to 10.3.1.2726 per suggestions provided, but am still seeing the same issues.
    Any download from Amazon appstore gets stuck and takes more than an hour for even a single app to get installed.
    Also, the Youversion app still doesn't work. Any input to solve this issue is highly appreciated.

    Friends,

    Since 04/10/2015, I'm seeing multiple issues while trying to use Amazon appstore from my BlackBerry Passport. I'm listing out the issues below so someone can help me figure out if this is widespread on all BlackBerry devices or if it's happening just in my phone

    1. I downloaded Youversion BIBLE app from appstore (I have the BlackBerry version of it, still prefer the Amazon one), and it got installed with an icon containing a circle, square and triangle. When I tried accessing the app, it just took me to home screen and did nothing. I did a reset of my phone and tried to install it again, but am still facing the same issue. So far, I haven't seen any success in getting the app to work.

    2. When I install any app from Amazon, the download process goes faster till 95%, then it gets stuck. I have to open the task from Notifications in hub (It says download complete), and then click on the app link to navigate to the app in the appstore. Even then, instead of the Install button, I see a button with no text. After a few hours when I access appstore, I get an install prompt and the app then installs and works fine. This is occurring for every app I download from Amazon (Even while re-installing the ones I already own)

    3. Most frequently, during downloads, appstore freezes and my phone becomes unresponsive. I have to long press the power button to restart my phone and redo the app installation.
    All the issues I'm currently seeing in my phone are only related to Amazon appstore. Every other feature works just fine and the phone becomes slower only while accessing Amazon appstore.
    I would sincerely appreciate any help you can offer with regards to this issue.

    OS version: 10.3.1.2726

    Thanks!

    Posted via CB10
    Last edited by giftsonbb; 04-14-15 at 12:03 AM. Reason: Issue still persists even after updating OS to latest version
    04-13-15 01:16 PM
  2. Bla1ze's Avatar
    OS version: 10.3.0.1779
    Why are you still on this OS? Update. According to your profile you're in the US and using a Passport, so that leads me to believe you bought it from Amazon or ShopBB in which case, there's no reason you shouldn't have an update available plus, you can always just update through Sachesi or via an autoloader.
    kbz1960 and giftsonbb like this.
    04-13-15 01:20 PM
  3. giftsonbb's Avatar
    Thanks Bla1ze for the quick response.
    I did check for updates in my device, but it says that I have the latest version, and doesn't provide me an option to update.
    04-13-15 01:24 PM
  4. giftsonbb's Avatar
    You're right! I bought my Passport from Amazon.
    But as I mentioned, I don't see an update when I tried through Settings. I will try updating through Autoloader and see if that solves the issue.

    Thank you very much for your help!!!
    04-13-15 01:56 PM
  5. Parrillas NY's Avatar
    No issues reported with the Amazon App store on BB Passport, Z10 STL100-1 and BB Q5 all devices updated with the last leak 10.3.1.2726 everything is OK.
    giftsonbb likes this.
    04-13-15 02:09 PM
  6. giftsonbb's Avatar
    No issues reported with the Amazon App store on BB Passport, Z10 STL100-1 and BB Q5 all devices updated with the last leak 10.3.1.2726 everything is OK.
    Thanks Parrillas!
    Were you able to update to 10.3.1.2726 from your Passport itself?
    I checked for updates, but it said I have the latest version running.
    BTW, I have an unlocked version of Passport.
    04-13-15 02:18 PM
  7. drbgd's Avatar
    I get exactly the same behaviour with 10.3.1.2582! I try to install Youversion Bible from Amazon, it downloads completely, but then I get a button with no text and clicking on it doesn't do anything. After I close the Amazon Appstore process multiple times (by using the device manager "close program"), the BB becomes completely unresponsive and I can't do anything other than reset it.
    Btw, Z30 here.
    05-07-15 05:43 AM
  8. asghardgr811's Avatar
    I suggest u to use another app instead of amazon.
    Lot of apps not available on Amazon.


    Posted via CB10
    05-07-15 09:18 AM

Similar Threads

  1. Replies: 3
    Last Post: 04-14-15, 12:23 PM
  2. Answer and hang up with space bar (Q10)
    By blackshark in forum BlackBerry Q10
    Replies: 2
    Last Post: 04-13-15, 03:04 PM
  3. How can I save my text messages on the Blackberry Classic?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 04-13-15, 12:02 PM
  4. Print to go not working on windows 8.1
    By Loc22 in forum Ask a Question
    Replies: 1
    Last Post: 04-13-15, 11:56 AM
  5. How do I forward text messages on my BlackBerry Passport?
    By CrackBerry Question in forum BlackBerry Passport
    Replies: 1
    Last Post: 04-13-15, 11:48 AM
LINK TO POST COPIED TO CLIPBOARD