1. CrackBerry Question's Avatar
    Hi Guys, I've got a problem with my Z30 that have not been able to solve in a long time. Whenever I try to start it up, it doesn't load at all. When pluggled, it seems like starting, that is: it turns the led red, then the blackberry symbol appears in the screen and immediately a red battery symbol appears, as if there´s no battery left. I've tried charging it for ours but it appears as if nothing ever charges. I've tried restoring the OS but hasn´t work and before this happenes, the phone was working fine just suddenly "poof", dead.

    I don't know if someone have experienced this, and if you do please tell me about a possible solution.

    Thanks!
    05-07-17 08:40 PM
  2. conite's Avatar
    Try another charger and cable.
    05-07-17 08:41 PM
  3. Manuel Basurto's Avatar
    Done that plenty of times, with different blackberry original chargers but hasn´t worked out :/
    05-07-17 08:53 PM

Similar Threads

  1. Replies: 4
    Last Post: 06-02-17, 09:31 AM
  2. A Few Days with the KeyOne - Thoughts so Far
    By buckshot_88 in forum BlackBerry KEYone
    Replies: 25
    Last Post: 05-09-17, 11:49 AM
  3. Whatsapp problem
    By Mukesh Kumar Prajapat in forum BlackBerry Q10
    Replies: 6
    Last Post: 05-09-17, 01:42 AM
  4. Replies: 4
    Last Post: 05-07-17, 03:06 PM
  5. My Blackberry Priv says "the UI app has had a problem"
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 05-07-17, 01:44 PM
LINK TO POST COPIED TO CLIPBOARD