1. SBence's Avatar
    Hi all,

    I'll start by saying I love everything about my Blackberry Keyone, except the bits I don't.

    In a nutshell I have a WIFI enabled thermometer which allows for remote monitoring over my phone data, but first it needs to be paired with an app whilst the phone is connected to the WIFI you are attempting to connect the thermometer to.

    This is where I'm running into issues, it either isn't liking the pairing process or isn't allowing the app to enter my WIFI password into what is effectively a third party device...in my strictly unprofessional opinion anyway, for reference it works fine on someone else's iphone.

    In not quite a nutshell and as per the guidelines for posting a question:
    - I have a Blackberry Keyone (based in UK if that makes a difference), running Android 8.1 which is the most update version currently available on the Keyone

    - I am running the most recent version of the app I am having issues with, and have uninstalled, reinstalled and cleared the cache etc (app says it requires Android 4.1 as a minimum)

    - The thermometer is only 2.4GHz WIFI enabled so my first thought was it was some weird thing my router or the app was doing because of my router being dual band and the fact my Keyone was defaulting to the 5GHz band. As I couldn't change the WIFI settings in Android 8.1 I went and got a 2.4GHz WIFI booster this didn't help, my phone didn't seem to want to connect to it not sure why.
    - The next step I took was to go into my router settings and separate the two bands, giving them individual passwords, so that devices can't automatically jump between the different bands/default to the best signal. This was done just in case the app had a bug that meant it couldn't pair with the thermometer because the thermometer was 2.4GHz and the Keyone was stuck on 5GHz though really this shouldn't be an issue. This did not help either.

    - I've tried changing every setting I could find for the app in my Keyone including allowing to run on startup/in the background, unrestricted data access etc but I can't find anything regarding pairing devices over WIFI/through an app

    - The only thing I can think of that I didn't try was an APN - but I'm not sure if this is applicable in this situation and wouldn't know where to look for, or how to word, an appropriate search. I've had the Priv and the Keyone on my current network and both required APNs to connect to my data and receive/send MMS

    - No error messages as such but there is one thing I noticed after trying it on an iphone and is also where I think the issue is manifesting
    - When pairing the thermometer with the app the phone needs to be connected to the WIFI, you then enter the WIFI password in the app to connect the thermometer to the WIFI simple.
    - When prompted for the password in the Android app it says SSID unknown but allows you onto the next stage and then searches until the countdown runs down and then 'fails to find device'
    - I know its connected to the WIFI though because as a test run I connected it to my data/not to any internet and at this stage it says please connect to WIFI and re-directs me to the relevant settings page - likewise under SSID unknown it says change connection which that takes my to the page displaying all available networks/shows I'm connected to my router
    - I've also tried it setting up a mobile hotspot and tried my neighbours wifi - granted the signal wasn't great on their WIFI so this might be a moot point
    - At this same stage on the iphone app it has my router name/SSID displayed and pairs with the thermometer without issue (not my iphone though so not really a practical work around)
    - For reference I paired the thermometer on the iphone app and it showed up in the android app as you have to login - and it works so long as the iphone is connected but the second the iphone app is closed or deleted the android app stops communicating with the thermometer/says the thermometer is disconnected
    - I don't have access to another Android phone to try it but I genuinely believe it is an issue with the Blackberry Keyone as there are no reviews, or online advice regarding the thermometer that seem to have this problem

    In reality it seems like an issue with some kind of setting or permission but with Android 8.1 you can't play around with WIFI settings and the only permission I managed to find that was even remotely close was 'pairing over bluetooth'. The thermometer is not bluetooth enabled/the reason I got this thermometer was because I have thick walls and will often need to run this thermometer when I'm away from the house, once paired over WIFI you can connect to the thermometer with your data.

    Not sure if I'm allowed to mention the company/thermometer on this forum - but if I am, and it might make a difference in diagnosing let me know.

    Any help/advice would be hugely appreciated.

    Apologies for the length of my query and thank you in advance for your time.

    Regards,

    Simon
    11-19-19 05:07 AM
  2. PantherBlitz's Avatar
    What is the make & model of the thermometer that you are using?
    11-19-19 10:17 AM
  3. Dunt Dunt Dunt's Avatar
    I'd expect this to be a general Android issue and not really related to the KEYone... have you looked at the manufactures support site or forums?

    By all means do a search on CrackBerry, but I'd also check out Android Central as well.
    11-19-19 11:59 AM
  4. SBence's Avatar
    Hi Panther Blitz, the thermometer is the Inkbird iBBQ 4T, the app is Inkbird Pro and is used to pair with various Inkbird devices both Wi-Fi and Bluetooth enabled.
    11-19-19 02:44 PM
  5. SBence's Avatar
    Thanks for the info. I had a search of various sources both Android and manufacturers but didn't find anything definitive it was mostly 'Wi-Fi not being picked up' etc. I will though try and widen the search as best I can the only problem being it is a relatively niche product.
    11-19-19 02:47 PM
  6. SBence's Avatar
    Tried a few other things, that didn't worked so changed it back.

    Issue seems to of resolved itself by the power of osmosis...don't know what witchcraft or trickery has happened but no issues pairing now, no updates installed either.

    Thanks guys
    11-22-19 04:04 AM

Similar Threads

  1. Charging and reset issues
    By TheAbstracted in forum BlackBerry KEY2 LE
    Replies: 5
    Last Post: 12-28-19, 03:36 PM
  2. BBM Android
    By gonstax in forum BlackBerry KEY2 LE
    Replies: 3
    Last Post: 11-19-19, 02:57 PM
  3. Ring Tone Issues
    By ubbulls in forum BlackBerry KEY2 LE
    Replies: 3
    Last Post: 11-19-19, 09:52 AM
  4. Changing the Key2 AZERTY phisical keyboard to QWERTY how will react?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 11-18-19, 07:11 AM
  5. My Blackberry Passport can not open apps?
    By RAFIUL ISLAM JESAN in forum BlackBerry 10 OS
    Replies: 0
    Last Post: 11-17-19, 12:25 PM
LINK TO POST COPIED TO CLIPBOARD