1. AkshayBalgi's Avatar
    I recently updated my OS to 10.3.1.1779 and since then whenever someone calls me, I either get unknown caller or un identified caller. How do I resolve this issue

    Posted via CB 10 from z10
    04-01-15 04:52 AM
  2. BMCruiser's Avatar
    I recently updated my OS to 10.3.1.1779 and since then whenever someone calls me, I either get unknown caller or un identified caller. How do I resolve this issue

    Posted via CB 10 from z10
    Are you talking about calls from contacts, or from everyone?

    The person calling you may have his caller ID switched off.

    Check that your celphone contacts are stored in the local account on the device (copy to "local contacts" if necessary)
    04-01-15 05:01 AM
  3. AkshayBalgi's Avatar
    No I am talking of everyone who calls me

    Posted via CB 10 from z10
    04-01-15 05:03 AM
  4. BMCruiser's Avatar
    No I am talking of everyone who calls me

    Posted via CB 10 from z10
    I had a similar (although not identical) issue once, after updating OS with an autoloader and re-syncing my contacts with Outllook. I had to copy them all to the phone's "local contacts" account in order to get the incoming call identification function to work again.

    In case you aren't already aware, the Contacts app is not without its set of issues (which BB is looking into), and in my experience it's quite easy to screw things up. Strongly suggest exporting all your contacts to a csv before fiddling. Save the csv elsewhere (I save mine on my SD card), so you can import them again if you need to.
    04-01-15 05:17 AM
  5. AkshayBalgi's Avatar
    I had a similar (although not identical) issue once, after updating OS with an autoloader and re-syncing my contacts with Outllook. I had to copy them all to the phone's "local contacts" account in order to get the incoming call identification function to work again.

    In case you aren't already aware, the Contacts app is not without its set of issues (which BB is looking into), and in my experience it's quite easy to screw things up. Strongly suggest exporting all your contacts to a csv before fiddling. Save the csv elsewhere (I save mine on my SD card), so you can import them again if you need to.

    Did it but still the same issue

    Posted via CB 10 from z10
    04-01-15 07:29 AM
  6. BMCruiser's Avatar
    Did it but still the same issue

    Posted via CB 10 from z10
    Sorry to hear that didn't work for you. Many have reported solving various issues by powering down, leaving the phone for an hour or so, and then switching on again. Removing the battery for a while is also supposed to help with some things. If neither of those actions help, maybe check the relevant thread (there should be one which deals with findings and fixes for your OS version), in case someone else has solved the issue.

    I did hear somewhere that software release 1779 (2576) was intended for BB Passport - it may be that you have the wrong OS installed .... anyone???

    Just fyi, I'm on a Z30, running OS release 1865, which has received quite good reports on these forums.
    04-01-15 09:13 AM
  7. AkshayBalgi's Avatar
    It was an issue with the service provider and hence I think whoever has issue with caller identity has to ask the service provider to re instate the account settings and then use it accordingly

    Posted via CB 10 from z10
    04-02-15 03:01 AM
  8. BMCruiser's Avatar
    It was an issue with the service provider and hence I think whoever has issue with caller identity has to ask the service provider to re instate the account settings and then use it accordingly

    Posted via CB 10 from z10
    Never heard of or experienced such SP issues before where I live. Glad you got it sorted though.
    04-02-15 03:19 AM

Similar Threads

  1. I can't connect with Roku stick
    By Jalas35 in forum BlackBerry Passport
    Replies: 1
    Last Post: 05-25-15, 08:53 AM
  2. Can I get some help with my new BlackBerry Q10 OS ISSUES?
    By CrackBerry Question in forum BlackBerry Q10
    Replies: 3
    Last Post: 04-02-15, 12:16 AM
  3. Replies: 3
    Last Post: 04-01-15, 02:54 PM
  4. Replies: 4
    Last Post: 04-01-15, 02:52 AM
  5. Blend & BlackBerry Link issues
    By yeo123 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-31-15, 10:36 PM
LINK TO POST COPIED TO CLIPBOARD