1. CrackBerry Question's Avatar
    I have tried a PC (Windows 10) and Mac (OS X El Capitan). I've uninstalled and reinstalled BB Link on both, but the software doesn't recognize the device. I've also tried different cables.
    09-26-16 07:57 PM
  2. BB-JAM215's Avatar
    Link hasn't been updated for more than a year. It doesn't support Windows 10 and the latest version 1607 has broken it fir most people.

    Exactly what happens when you try to connect your Classic via USB?
    Does Link startup OK?
    Was it working before?
    Which version of BB10 are you using?
    09-26-16 08:08 PM
  3. logansm's Avatar
    Hi,
    Exactly what happens when you try to connect your Classic via USB?
    - BBLink fires up, but it doesn't seem to find my device.It shows connected to an old BB, oddly enough. It used to show the right one. Message - Can't Communicate with Device, then: Try reconnecting your device to your computer. If the device doesn't respond, click Restore Device. Blackberry Link will restore your device to its factory settings by reinstalling the device software. (This of course, wipes all my data, which is what I want to avoid.).
    Does Link startup OK?
    - Yes, but it doesn't recognize my BB. In fact, it displays an old BB as connected, but "cannot communicate with device".).
    Was it working before?
    - Yes, but a few weeks ago it stopped.
    Which version of BB10 are you using?
    - 10.3.2.2474
    09-27-16 01:25 PM
  4. BB-JAM215's Avatar
    I can't check this now because Link no longer runs on my Win 10 PC, but every time I connected via USB, I got the Connection Failed message, then just I chose re-connect or whatever (ignoring the Restore option) and it worked.
    09-27-16 01:55 PM
  5. BB-JAM215's Avatar
    Sound like you're having Issue 2 as described by Freakinvibe today in this thread regarding Link: http://forums.crackberry.com/blackbe.../#post12603243
    Last edited by BB-JAM215; 09-27-16 at 02:31 PM.
    09-27-16 02:17 PM
  6. logansm's Avatar
    FYI, I connected my old BB Z10 and the same issue occurred. However, the Device Name changed to Blackberry D3EC, which is the same as the newer Classic which shows on the BB Link page as B112. Odd, but both BB's show D3EC in the "About" section of the BB System Settings.
    09-27-16 02:28 PM
  7. MarcoAndre's Avatar
    My BlackBerry Link doesn't even start up, it crashes. I tried uninstalling and reinstalling with a reboot and still the same

    Posted via CB10
    09-27-16 02:58 PM

Similar Threads

  1. Is anyone running fitness tracker app on Passport with fitness bands
    By heading4tomorrow in forum BlackBerry Passport
    Replies: 24
    Last Post: 10-25-16, 08:39 PM
  2. Google is listening to your conversations
    By Velocitymj in forum General BlackBerry Discussion
    Replies: 118
    Last Post: 10-08-16, 08:00 AM
  3. My battery is getting worse.
    By dcal1701 in forum BlackBerry Passport
    Replies: 5
    Last Post: 09-28-16, 04:58 PM
  4. How to recover chats if the contact has been deleted?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-26-16, 09:58 PM
  5. How to reveal passwords I saved in the browser?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-26-16, 04:11 PM
LINK TO POST COPIED TO CLIPBOARD