1. bowline5's Avatar
    It all began when the phone threw a wobbler and refused to accept a charge unless I switch it off and reboot it; even when I do that and leave it on charge for six hours or so, the battery runs down to nothing in barely more than a day, where it used to last for three or four days if not used much. I thought a factory reset might be a good idea but I cannot get a usb connection to the laptop. I disabled the wi-fi connection option to try to force it to use the usb, now of course I can't turn the wi-fi back on because I can't get a usb connection. I've tried rebooting the phone while it's connected to the computer, I've removed and reinstalled Blackberry Link, I've booted up the computer while the phone is plugged in, nothing works. The handset is less than a year old. What do I do? Is this handset now no more than junk, or can it be brought back to some sort of functional value? Help please.
    06-20-17 08:35 AM
  2. BB-JAM215's Avatar
    It all began when the phone threw a wobbler and refused to accept a charge unless I switch it off and reboot it; even when I do that and leave it on charge for six hours or so, the battery runs down to nothing in barely more than a day, where it used to last for three or four days if not used much. I thought a factory reset might be a good idea but I cannot get a usb connection to the laptop. I disabled the wi-fi connection option to try to force it to use the usb, now of course I can't turn the wi-fi back on because I can't get a usb connection. I've tried rebooting the phone while it's connected to the computer, I've removed and reinstalled Blackberry Link, I've booted up the computer while the phone is plugged in, nothing works. The handset is less than a year old. What do I do? Is this handset now no more than junk, or can it be brought back to some sort of functional value? Help please.
    Its actually Link that is now junk. It sounds like your problems have more to do with Link not working than with your phone. Link is now out of date, won't be updated, and stopped working for many people about nine months ago. The situation has only gotten worse since then. And as much as you may have depended on Link, there's not much that can't be done without it.

    The good news is that the Windows USB drivers installed with Link will still work. Connect your phone to your computer and open a File Explorer window. You will probably have to scroll down to the bottom, but you should eventually see your phone memory and SD card if present mapped with drive letters. Mine mapped to Y and Z and I created shortcuts for them.

    If still think you need to wipe your phone and re-install BB10, you can do that with an auto-loader instead of Link, but make sure you back up all your personal data from your phone to your computer first over USB. Many people have been worse off after not being able to do a restore from Link.
    06-20-17 10:31 AM
  3. Dunt Dunt Dunt's Avatar
    Do a search here for LINK problems ... as the are numerous, and you'll just have to try them.

    iTune patch is one that many have been successful with. But if you are running Windows 10, it might not ever work again. Maybe see if someone has another PC you could use it on.

    There are a few Backup Apps in BBW... Ultimate Backup is one. Use it and save the info to a Cloud Service like ONEDRIVE. Then do a security wipe of the phone, but my guess is it's hardware related.
    06-20-17 10:34 AM
  4. kbz1960's Avatar
    Windows Explorer doesn't list it either?
    06-20-17 10:44 AM
  5. bowline5's Avatar
    Thanks for all the comments, I am still concerned that the problem is with the handset. In the past, as soon as I connected the usb cable I got an options screen, Charge only, Access SD Card etc, but it does not come up now. Windows explorer does not show the two drives, although they were there yesterday mapped Y and Z before I disabled the wi-fi connection. Today Windows failed to install the device drivers when I plugged in. All this and the battery issue worries me that a hardware issue has made the phone completely impractical.
    06-21-17 07:14 AM
  6. bowline5's Avatar
    Thanks for all the comments, I am still concerned that the problem is with the handset. In the past, as soon as I connected the usb cable I got an options screen, Charge only, Access SD Card etc, but it does not come up now. Windows explorer does not show the two drives, although they were there yesterday mapped Y and Z before I disabled the wi-fi connection. Today Windows failed to install the device drivers when I plugged in. All this and the battery issue worries me that a hardware issue has made the phone completely impractical. Here's a new one, I've just unplugged the phone from charging and got a message about USB Surge Protection, usb host mode is turned off. It tells me to connect the OTG Dongle or Host Mode Cable to re-enable host mode. Translation anyone?
    06-21-17 07:39 AM
  7. kbz1960's Avatar
    Sounds like the port is going bad. Have you tried putting a little pressure, not much, on the cable on way or another?
    06-21-17 08:31 AM
  8. kbz1960's Avatar
    Hum, didn't know that phone has USB otg which means you can access a thumb drive etc with an adapter
    06-21-17 08:32 AM
  9. bowline5's Avatar
    So if I get an OTG Dongle, what do I connect it to? I spoke today to a recommended local repairer, he told me he cannot do anything to re-enable the USB host mode, Blackberry have withdrawn all software support and shut down their servers so he has no access to any of the drivers or other software for Blackberry OS phones that he used to have. Apparently if we users don't upgrade to one of the new android models, RIM don't want to know about us. My first ever cell phone, in 1992, had a better battery standby than this one and that was a 200 x 30 mm lead acid brick!
    06-24-17 01:38 PM

Similar Threads

  1. Replies: 42
    Last Post: 06-22-17, 03:40 PM
  2. VERIZON - Travel Pack to Canada not provisioned!
    By capital_M in forum BlackBerry KEYone
    Replies: 9
    Last Post: 06-21-17, 01:42 PM
  3. Replies: 3
    Last Post: 06-20-17, 03:46 PM
  4. One email account slow to appear in hub
    By rwilliams1867 in forum BlackBerry Priv
    Replies: 5
    Last Post: 06-20-17, 10:29 AM
  5. Soft bricked Blackberry Classic (what to do?)
    By Kubas_inko in forum BlackBerry Classic
    Replies: 8
    Last Post: 06-20-17, 07:19 AM
LINK TO POST COPIED TO CLIPBOARD