07-20-17 02:27 PM
31 12
tools
  1. grl69sa's Avatar
    BB Z30, running OS 10.3.3.1463, T Mobile carrier. Recently the icon of WiFi calling appeared in upper right corner. When WiFi turned on, text messages do not go through, particularly MMS. T mobile can't resolve this issue. How to turn that WiFi calling option off ?
    Thank you.

    EDITED: There is no T mobile app, neither I can download it .
    Last edited by grl69sa; 04-05-17 at 05:25 PM.
    04-05-17 04:03 PM
  2. coffee-turtle's Avatar
    search for the Tmobile "Wi-Fi Calling" app on your phone. The settings are there.
    04-05-17 04:27 PM
  3. grl69sa's Avatar
    There is no T mobile app, neither I can download it .
    04-05-17 05:35 PM
  4. grl69sa's Avatar
    There is no T mobile app, neither I can download it .
    04-05-17 06:58 PM
  5. coffee-turtle's Avatar
    Did you try here: BlackBerry World: https://appworld.blackberry.com/webs...ode=IE&lang=en

    If above failed:

    Are you familiar with sideloading .bar files with Sachesi?
    http://forums.crackberry.com/bb10-le...taller-825409/

    You will also need this bar file: tmowificallingsettings-10.1.1.127-nto+armle-v7+signed.bar
    My temporary share for you: https://goo.gl/Ylcewl

    Though I read that Sachesi may have it already to install?
    http://forums.crackberry.com/blackbe...ialing-968090/


    You may also have to do these additional steps:

    Turn on Development Mode at Settings - Security and Privacy.


    Turn on Flight Mode.
    On Sachesi; Instal BAR files, Select all BAR file at folder and click Instal.
    04-06-17 01:35 PM
  6. JSmith422's Avatar
    BB Z30, running OS 10.3.3.1463, T Mobile carrier. Recently the icon of WiFi calling appeared in upper right corner. When WiFi turned on, text messages do not go through, particularly MMS. T mobile can't resolve this issue. How to turn that WiFi calling option off ?
    Thank you.

    EDITED: There is no T mobile app, neither I can download it .
    Same issue here. Just popped up again last night. T-mobile sends some signal to your device periodically (seems like every 6 months), and it messes things up on at least the Z30's. I've had SOME success calling in (immediately ask to be transferred to a supervisor to save yourself some time), then ask them to refresh the connection. After the connection has refreshed, reboot your phone. This usually takes care of most of the problems including the icon in the right hand corner. That said, I'm almost never on WiFi and I'm still running 10.3.2. I've never tried it with 10.3.3 so it could be different.....I don't trust the 10.3.3 build yet, have heard of way too many issues and I need stable and fully baked. Let me know what you figure out.

    Also, you will need to delete the notification (if there is one) regarding wifi calling from your hub. Do this before you refresh the connection and reboot.

    Posted via CB10
    04-06-17 06:31 PM
  7. grl69sa's Avatar
    Thank you for the response. After I read your post, I've had T mobile tech worked on this issue with no success. I also have Blackberry Passport, running 10.3.2 and absolutely no problems I am experiencing with Z30. It seems the culprit is BB itself, rather then T Mobile.
    I actually got my Z30 7 months ago, and I noticed it gets warm and turns off/restart when I use certain apps, particularly Viber. Once, while in use the phone got very hot, shut off and later on I found out the microphone was broken . Since the phone was under the factory warranty, after the store where I bought the phone referred me to Blackberry, I was told by BB customer service, when they run IMEI that I've bought defective device and the factory warranty was expired a month before i purchased it, AND they are not responsible for it (?) At least, that phone worked on Wi-Fi...
    Long story short, I've got replacement phone, brand new, 2 months ago, and it worked great. Suddenly ( again) the phone restarted by itself, that Wi-Fi call icon appeared, and after that I started having the issues with calls and text messages while on Wi-Fi. Blackberry charges $30 for troubleshooting. As much as I love BB, I am getting tired of to many limitations that come with it and zero effort from BB to resolve the issue ( I found them rude and with bad attitude).
    Last edited by grl69sa; 04-27-17 at 01:23 AM.
    04-27-17 12:49 AM
  8. grl69sa's Avatar
    That App does not exist for BB Z30, or for the OS that it runs on. I used to have it on my Z10, and it came as default App with T mobile, where I purchased that phone at the time.
    I am not familiar with the Sachesi, and I am not sure how would it help in this case. However, thank you for your time and effort to help me resolve this.
    Last edited by grl69sa; 04-27-17 at 01:22 AM.
    04-27-17 01:01 AM
  9. JSmith422's Avatar
    Thank you for the response. After I read your post, I've had T mobile tech worked on this issue with no success. I also have Blackberry Passport, running 10.3.2 and absolutely no problems I am experiencing with Z30. It seems the culprit is BB itself, rather then T Mobile.
    I actually got my Z30 7 months ago, and I noticed it gets warm and turns off/restart when I use certain apps, particularly Viber. Once, while in use the phone got very hot, shut off and later on I found out the microphone was broken . Since the phone was under the factory warranty, after the store where I bought the phone referred me to Blackberry, I was told by BB customer service, when they run IMEI that I've bought defective device and the factory warranty was expired a month before i purchased it, AND they are not responsible for it (?) At least, that phone worked on Wi-Fi...
    Long story short, I've got replacement phone, brand new, 2 months ago, and it worked great. Suddenly ( again) the phone restarted by itself, that Wi-Fi call icon appeared, and after that I started having the issues with calls and text messages while on Wi-Fi. Blackberry charges $30 for troubleshooting. As much as I love BB, I am getting tired of to many limitations that come with it and zero effort from BB to resolve the issue ( I found them rude and with bad attitude).
    If you followed all of the steps I outlined, including deleting the notification, calling T-Mobile and having your connection fully refreshed (something they do on their end) and then rebooting the device, and didn't have any success, then......

    Unless you need 10.3.3 for some reason, I'd suggest reloading 10.3.2 and see if it resolves your problem. And again following the steps outlined above (if need be). There are lots of autoloaders available, but be sure to make a backup of the device before installing.

    The issue you describe sounds EXACTLY like mine, and T-MOBILE wanted to blame blackberry as well, they told me they'd never heard of the issue and it must be a blackberry problem.....even though I had personally brought it to their attention twice in the past year.

    Like I said, it seems to have to do with a signal that T-Mobile sends to the device, and it happens every 6 months or so. I can't speak to the overheating issue, but I know T-Mobile definitely sends a signal to the device, and it definitely causes the problems you describe in the Z30's.

    Posted via CB10
    04-27-17 07:20 PM
  10. nhatanh181's Avatar
    You must download/steal the Tmoble wifi calling app in order to turn it off. Try the instruction above.

    Posted via Blackberry Passport
    04-27-17 10:04 PM
  11. Jamaa's Avatar
    Can't believe I have to keep posting this. There is a search feature on this forum you know?


    Here you go:

    http://appworld.blackberry.com/webst...ntent/35524900

    Install this and you'll be able to have full control on turning OFF, setting options or turning ON the wifi calling feature.

    It works with ALL BB10 phones on ALL networks worldwide to control the wifi calling features.


     Q10 SQN100-5/10.3.3.2049 T-Mobile with Wi-Fi calling
    04-27-17 11:17 PM
  12. Jamaa's Avatar
    04-27-17 11:23 PM
  13. grl69sa's Avatar
    Really ? How about you read the previous post(s).
    04-28-17 07:31 PM
  14. grl69sa's Avatar
    04-28-17 07:32 PM
  15. grl69sa's Avatar
    Thank you all who think ( and direct me) to download an Wi-Fi Calling App. IT IS NOT POSSIBLE to download it, for the simple reason -IT DOES NOT exist in BB World.
    04-28-17 07:36 PM
  16. Jamaa's Avatar
    Thank you all who think ( and direct me) to download an Wi-Fi Calling App. IT IS NOT POSSIBLE to download it, for the simple reason -IT DOES NOT exist in BB World.
    Wrong.

    Click my first link, THEN apologize.

    I just clicked on it, and guess what? Voila!


    How to turn off WiFi calling on BB Z30-img_20170428_163835.png

    The previous link you had been given WAS a region specific link that would not allow you to access the app on BlackBerry world.

    Apologize.

    Now.

     Q10 SQN100-5/10.3.3.2049 T-Mobile with Wi-Fi calling
    04-28-17 07:40 PM
  17. grl69sa's Avatar
    The link led me here. I apologize.

    That happened when clicked on link.

    However, when opened the link on my PC, I was able to see the page. Tried to email the link from the web page, kept getting error message.

    Also:

    Copy - paste(d) the link to open it in the phone browser - I've got the message the Page no longer exist.
    Attached Thumbnails How to turn off WiFi calling on BB Z30-img_20170428_195938.png   How to turn off WiFi calling on BB Z30-img_20170428_195949.png  
    Last edited by grl69sa; 04-28-17 at 08:42 PM.
    04-28-17 08:04 PM
  18. Jamaa's Avatar
    The link led me here. I apologize.

    That happened when clicked on link.

    However, when opened the link on my PC, I was able to see the page. Tried to email the link from the web page, kept getting error message.

    Also:

    Copy - paste(d) the link to open it in the phone browser - I've got the message the Page no longer exist.
    You can't figure out how to click the BlackBerry world links above and come here complaining that we are giving you bad links?

    FYI, you should click on those links only from your phone. Copy and pasting is the wrong approach & will certainly not work when clicking on a PC.

     Q10 SQN100-5/10.3.3.2049 T-Mobile with Wi-Fi calling
    04-28-17 09:51 PM
  19. grl69sa's Avatar
    I posted you screen shoots of the BB World where that link led me.

    I apologize if you can't figure out what I tried to do to make the link work.

    I tried that link again. Got to the app you posted above, BUT ... why nothing happens when touch Open ? It looks like screen shot.
    04-28-17 11:29 PM
  20. grl69sa's Avatar
    If you followed all of the steps I outlined, including deleting the notification, calling T-Mobile and having your connection fully refreshed (something they do on their end) and then rebooting the device, and didn't have any success, then......

    Unless you need 10.3.3 for some reason, I'd suggest reloading 10.3.2 and see if it resolves your problem. And again following the steps outlined above (if need be). There are lots of autoloaders available, but be sure to make a backup of the device before installing.

    The issue you describe sounds EXACTLY like mine, and T-MOBILE wanted to blame blackberry as well, they told me they'd never heard of the issue and it must be a blackberry problem.....even though I had personally brought it to their attention twice in the past year.

    Like I said, it seems to have to do with a signal that T-Mobile sends to the device, and it happens every 6 months or so. I can't speak to the overheating issue, but I know T-Mobile definitely sends a signal to the device, and it definitely causes the problems you describe in the Z30's.

    Posted via CB10
    It seems to me it is up to 10.3.3, or BB in general.

    I am wondering, does it matter that phone is bought unlocked, it is not T mobile phone. I have unlocked Passport that does not show WiFi icon in BB world either, but has no that issue, and run on 10.3.2.2226
    04-28-17 11:51 PM
  21. JSmith422's Avatar
    It seems to me it is up to 10.3.3, or BB in general.

    I am wondering, does it matter that phone is bought unlocked, it is not T mobile phone. I have unlocked Passport that does not show WiFi icon in BB world either, but has no that issue, and run on 10.3.2.2226
    I'm using an unlocked Z30 purchased directly from Blackberry. Running software release 10.3.2.2836.

    I've followed the steps I outlined above on three separate occasions and my phone is working fine. That said, I almost never use wifi, so everything is pretty much done over the T-Mobile network.

    Based on the timing of the issue with your device, and the exact same symptoms, I'm almost certain you received the same signal I did. T-mobile support was useless to deal with, you just need to tell them what you need them to do.

    I had some trouble opening the link to the T-mobile app listed above as well, but I did finally to it by pressing the refresh button a few times. I didn't download anything because I'm a believer in "if it ain't broke, don't fix it." But that may be another option for you.

    Posted via CB10
    04-29-17 12:13 AM
  22. grl69sa's Avatar
    It seems to me it is up to 10.3.3, or BB in general.

    I am wondering, does it matter that phone is bought unlocked, it is not T mobile phone. I have unlocked Passport that does not show WiFi icon in BB world either, but has no that issue, and run on 10.3.2.2226
    Actually, T mobile has troubleshooting script for Blackberry regarding this matter. The tech I spoke to really tried hard to help me resolve this issue, we repeatedly went together over the phone functions that are affected with this feature. I am trying to reason: I have T Mobile Z10 that have pre-loaded App for WiFi Calling that I never used since, at the time, it was paid feature, but allowed to the device to turn it on and off. Passport run on 10.3.2 and has no this issue, while Z30 run 10.3.3, and for two of those is common that are both unlocked phones, and none of them can't "see" WiFi App in BB World. Why those phones are not able to "see" that App ?

    I was thinking to downgrade to 10.3.2 too, did some research and found out that downgrading itself does not resolve the issue. Not sure If I am going to try it .
    04-29-17 12:18 AM
  23. grl69sa's Avatar
    I'm using an unlocked Z30 purchased directly from Blackberry. Running software release 10.3.2.2836.

    I've followed the steps I outlined above on three separate occasions and my phone is working fine. That said, I almost never use wifi, so everything is pretty much done over the T-Mobile network.

    Based on the timing of the issue with your device, and the exact same symptoms, I'm almost certain you received the same signal I did. T-mobile support was useless to deal with, you just need to tell them what you need them to do.

    I had some trouble opening the link to the T-mobile app listed above as well, but I did finally to it by pressing the refresh button a few times. I didn't download anything because I'm a believer in "if it ain't broke, don't fix it." But that may be another option for you.

    Posted via CB10
    Well, I gave it a try couple of times after I read this post. Unfortunately, I kept getting the same screen as I posted above.
    04-29-17 12:30 AM
  24. Jamaa's Avatar
    I will give you guys the correct link again:

    http://appworld.blackberry.com/webst...ntent/35524900

    Click this link from your Blackberry cell phone.

     Q10 SQN100-5/10.3.3.2049 T-Mobile with Wi-Fi calling
    04-29-17 02:06 AM
  25. Jamaa's Avatar
    It will take you direct to here to download it. I just clicked it, BlackBerry world opened the app download page and took these screen shots to prove that the link works:



    How to turn off WiFi calling on BB Z30-img_20170428_230704.png


    How to turn off WiFi calling on BB Z30-img_20170428_230714.png


    How to turn off WiFi calling on BB Z30-img_20170428_230718.png

     Q10 SQN100-5/10.3.3.2049 T-Mobile with Wi-Fi calling
    04-29-17 02:10 AM
31 12

Similar Threads

  1. Replies: 6
    Last Post: 04-10-17, 03:21 AM
  2. BB Classic stuck on "finalizing device setup?"
    By CrackBerry Question in forum Ask a Question
    Replies: 5
    Last Post: 04-07-17, 10:24 AM
  3. Replies: 2
    Last Post: 04-06-17, 08:53 AM
  4. Ultimate server app and vpn for bb 10?
    By nhatanh181 in forum Ask a Question
    Replies: 2
    Last Post: 04-06-17, 07:04 AM
  5. BlackBerry Secure webinar taking place on April 6
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 04-05-17, 03:30 PM
LINK TO POST COPIED TO CLIPBOARD