1. CrackBerry Question's Avatar
    need skype for torch 9810
    11-22-14 12:36 PM
  2. RyanGermann's Avatar
    ...I'm sorry to say what you need is a new device, because Skype was never released for BBOS devices (well, it was sort of on BBOS devices on Verizon or something, but it never worked really well and was never released widely, probably because it never worked well).
    11-22-14 12:52 PM
  3. JamBueree's Avatar
    You need a BlackBerry 10 device to be able to download and install Skype.

    BlackBerry Z10 |
    11-22-14 06:30 PM

Similar Threads

  1. Found a great leather wallet/sleeve for the Passport
    By BravoZuluDelta in forum BlackBerry Passport
    Replies: 4
    Last Post: 02-19-15, 04:12 PM
  2. Trackpad vs. Passport: What's better for text manipulation?
    By djbclark in forum BlackBerry Passport
    Replies: 11
    Last Post: 11-24-14, 09:50 AM
  3. Replies: 0
    Last Post: 11-22-14, 10:15 AM
  4. Replies: 0
    Last Post: 11-22-14, 09:31 AM
  5. Replies: 2
    Last Post: 11-22-14, 09:22 AM