1. Matt Beyea's Avatar
    I have had issues now for a while trying to log into hotel Wi-Fi networks. Travel all the time for work and the last few times I travel.....as soon as I turn on my Wi-Fi it will automatically log into the (example Westin guestroom network) ...it will say CONNECTED without prompting me to put my room number or name etc. It just says connected yet there is absolutely no internet. I've tried going into to network and clicking "FORGET" the network.......but the same thing keeps happening.

    So I end up not having any internet thanks to this issue. I've even tried rebooting the phone with no luck ..... Please help!
    01-21-20 11:59 PM
  2. Chuck Finley69's Avatar
    I have had issues now for a while trying to log into hotel Wi-Fi networks. Travel all the time for work and the last few times I travel.....as soon as I turn on my Wi-Fi it will automatically log into the (example Westin guestroom network) ...it will say CONNECTED without prompting me to put my room number or name etc. It just says connected yet there is absolutely no internet. I've tried going into to network and clicking "FORGET" the network.......but the same thing keeps happening.

    So I end up not having any internet thanks to this issue. I've even tried rebooting the phone with no luck ..... Please help!
    What happens when you open a browser? Does it prompt you normally? Have you called tech support for the hotel when this happens with any help from their side?

    I’ve had this happen in the past on Android/iOS devices when the network has been accepted previously. Are you able to forget the network and start from beginning?
    Last edited by Chuck Finley69; 01-22-20 at 08:25 AM.
    01-22-20 07:46 AM
  3. falbo's Avatar
    I have had issues now for a while trying to log into hotel Wi-Fi networks. Travel all the time for work and the last few times I travel.....as soon as I turn on my Wi-Fi it will automatically log into the (example Westin guestroom network) ...it will say CONNECTED without prompting me to put my room number or name etc. It just says connected yet there is absolutely no internet. I've tried going into to network and clicking "FORGET" the network.......but the same thing keeps happening.

    So I end up not having any internet thanks to this issue. I've even tried rebooting the phone with no luck ..... Please help!
    What type of phone is this happening with Matt ?
    As you have been a member of this forum for a good few years is it safe to say that it's a blackberry and if so which one.
    If it's a older type phone maybe that's part of the reason.
    Of course someone else with better tech skills May stumble upon this post and will be able to help,good luck and I hope you get it sorted soon.



    Posted via my beautiful priv
    01-22-20 08:21 AM
  4. Matt Beyea's Avatar
    I apologize, I have they key2 nowadays , that's what I'm having issues with for hotel Wi-Fi
    for example at this Westin hotel I'm at currently it automatically grabs the Westin guestroom network, says connected but there is no data going through , I then go and select Westin lobby , it also says connected.
    I did try to go into the network details and "forget" them all but the same thing keeps happening.
    01-22-20 08:52 AM
  5. bb10adopter111's Avatar
    This is an issue on my KEYone as well. After connecting to the network it doesn't redirect to the appropriate login page.

    In my case the only browser I have installed on my KEYone is Firefox Focus, and I suspect there is a security control BlackBerry turned on when they linked Focus to the Locker. Prior to the update that added the locker, I never experienced this issue.

    I haven't bothered to try this with Chrome installed, but I wouldn't be surprised if BlackBerry and BlackBerry Mobile never tested this functionality fully. That's what happens with smaller development teams.

    Z10 = BB10 + VKB > iOS + Android
    01-22-20 09:04 AM
  6. ppeters914's Avatar
    Too bad there are no command line commands to flush out all Wi-Fi settings like in Windows.

    1. Delete/forget *ALL* Wi-Fi networks, not just Westin's. I once (twice?) had to do that. But don't try to reconnect yet.

    2. Turn Wi-Fi OFF.

    3. Clear your browser cache of *EVERYTHING* since the beginning.

    4. Close everything (aka CLEAR ALL in Android).

    5. Restart your phone.

    6. Turn Wi-Fi ON, but don't connect to anything.

    7. Restart phone again.

    8. Now try connecting Wi-Fi.

    Working?
    01-22-20 11:42 AM
  7. Bla1ze's Avatar
    I have had issues now for a while trying to log into hotel Wi-Fi networks. Travel all the time for work and the last few times I travel.....as soon as I turn on my Wi-Fi it will automatically log into the (example Westin guestroom network) ...it will say CONNECTED without prompting me to put my room number or name etc. It just says connected yet there is absolutely no internet. I've tried going into to network and clicking "FORGET" the network.......but the same thing keeps happening.

    So I end up not having any internet thanks to this issue. I've even tried rebooting the phone with no luck ..... Please help!
    One thing to keep in mind is that Hotel WiFi also hates when you use your own DNS (such as 1.1.1.1 or Google DNS) settings or are using a VPN. if you have any of those active, you may wish to consider disabling them and trying.
    Laura Knotek likes this.
    01-22-20 01:58 PM
  8. The_Passporter's Avatar
    I have had issues now for a while trying to log into hotel Wi-Fi networks. Travel all the time for work and the last few times I travel.....as soon as I turn on my Wi-Fi it will automatically log into the (example Westin guestroom network) ...it will say CONNECTED without prompting me to put my room number or name etc. It just says connected yet there is absolutely no internet. I've tried going into to network and clicking "FORGET" the network.......but the same thing keeps happening.

    So I end up not having any internet thanks to this issue. I've even tried rebooting the phone with no luck ..... Please help!
    This happened to me when in L.A. At a hotel and after googling for a solution I found that if after I'm connected I go in Stock browser and type a legit website like "CBC.ca" or something it will then redirect me to the wifi sign in page.
    Now I know this was BB10 but thought to mention it since nothing else is working for you. Also I'm not sure that was the website I used but should work if that's The issue.

    Hammered out on my Precious Passport.
    Matt Beyea likes this.
    01-22-20 02:06 PM
  9. ppeters914's Avatar
    One thing to keep in mind is that Hotel WiFi also hates when you use your own DNS (such as 1.1.1.1 or Google DNS) settings or are using a VPN. if you have any of those active, you may wish to consider disabling them and trying.
    True, but if it had been working with these or not, and now isn't working, then I think there's a high probability of corrupted, cached stuff especially since OP says he travels regularly.

    Ran into this constantly in prior IT support job, and my own devices occasionally.
    Bla1ze likes this.
    01-22-20 02:11 PM
  10. Matt Beyea's Avatar
    That totally worked passport"er. Thank you. Type in CBC.*ca* and it instantly went to hotel login page!!
    Cheers!!!
    01-22-20 05:13 PM
  11. bb10adopter111's Avatar
    One thing to keep in mind is that Hotel WiFi also hates when you use your own DNS (such as 1.1.1.1 or Google DNS) settings or are using a VPN. if you have any of those active, you may wish to consider disabling them and trying.
    Very good point. I don't think that's been my issue, but it is definitely an important troubleshooting step. In some cases, such as 1.1.1.1, you can re-enable the service after connecting.

    Z10 = BB10 + VKB > iOS + Android
    01-22-20 06:15 PM
  12. The_Passporter's Avatar
    That totally worked passport"er. Thank you. Type in CBC.*ca* and it instantly went to hotel login page!!
    Cheers!!!
    Awesome! I'm glad it worked for you. Cheers!

    Hammered out on my Precious Passport.
    Matt Beyea likes this.
    01-22-20 06:17 PM
  13. PwrSurge's Avatar
    The key here is to browse to an http and not a https website as most modern Web browsers nowadays are now configured to prevent any redirects to other websites such as a hotspot login page when browsing any https website.

    More and more websites such as Google are now configured to only connect via https which will stop redirects to captive portals from working.


    Posted via CB10
    01-24-20 12:12 AM

Similar Threads

  1. Sci-fi chat (open) group
    By Mwanahabari in forum Discover BBM Groups
    Replies: 5
    Last Post: 02-19-20, 04:12 PM
  2. BlackBerry KEY2 LE compatibility with Verizon Network?
    By denuccid in forum Ask a Question
    Replies: 5
    Last Post: 02-12-20, 02:07 AM
  3. How can I unlock the sim network?
    By Reymart Jose in forum BlackBerry Classic
    Replies: 5
    Last Post: 02-09-20, 04:17 PM
  4. Direct connection over Wi-Fi
    By ShaneGoodman in forum BlackBerry KEY2
    Replies: 2
    Last Post: 01-18-20, 10:32 PM
  5. No network on BlackBerry KEY2
    By 1984_5 in forum Ask a Question
    Replies: 11
    Last Post: 01-16-20, 07:01 PM
LINK TO POST COPIED TO CLIPBOARD