1. Joseph MO's Avatar
    I bought a branded 9790 which was working fine until a couple of weeks ago when my pings wouldn't deliver, I have a working BIS on it, I have tried my sim card on numerous phones at it works but on mine it's asking me for Enterprise Activation. I have used BIS and never BES so this is surprising. I have gone to my network provider and they are stuck too because it shows on my phone that I am registered on the blackberry network and I have the 3G with Logo,
    I have wiped the phone numerous times, deleted service books, i have tried different OS of various carriers but it always brings me back to the enterprise activation still.
    Nothing works...BBM, Whatsapp, Web-browser....It's just so tiring

    Someone said perhaps I have been deactivated by RIM but that'll be very surprising. Please I would appreciate any and every advice,

    Thanks.
    Attached Thumbnails Help needed with 9790.-screencapture.jpg  
    08-24-14 10:24 AM
  2. raino's Avatar
    If you are not the first owner of this phone, it's possible there was a BES policy on this phone previously. Try this: http://forums.crackberry.com/desktop...anager-693936/
    08-24-14 09:57 PM

Similar Threads

  1. Eight active frames with 10.3
    By DavideaNY in forum BlackBerry Z3
    Replies: 21
    Last Post: 08-28-14, 12:14 PM
  2. playbook app manager loging in problem please help !
    By anas1929 in forum Ask a Question
    Replies: 4
    Last Post: 08-26-14, 12:22 PM
  3. Help me with contact retrieval
    By santhoshmanikandan in forum BB 10 Developers Hangout
    Replies: 3
    Last Post: 08-24-14, 07:43 PM
  4. dilemma with restore on bb10 (q10)
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-24-14, 06:22 PM
  5. [BBC] Researchers hack Gmail app with 92% success
    By masser1956 in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 08-24-14, 07:14 AM
LINK TO POST COPIED TO CLIPBOARD