1. CrackBerry Question's Avatar
    So, I've had the Dtek60 for several weeks now and have been very pleased with it. I had to replaced my PRIV due to external damage (woops).

    I've noticed over the last few days that it is performing very slowly. In fact, it will seem okay, and then all of a sudden just go very sluggish. In fact, even slacker radio offline play gets glitchy and Web browsing feels like dial up again (also typing emails and text msgs).

    I read another post that suggested rebooting and clearing cache as an option. Neither of which I am okay with, however it does seem quicker. The reason I feel this way is I NEVER had this issue on my PRIV. It was a very rare occasions that I ever needed to reboot my PRIV. I have been very careful about the Apps I have installed. I have refrained from installing any games and only have a few other Apps like Slacker, expensify, bitmoji, es file explorer, youtube, Dropbox and ACR (call recorder). All of which I had on my PRIV.

    I have also set media to store on the sdcard.

    Is there some way to tell what process is consuming all the resources? Or maybe if the processor is slowed down? Could it be a slow Internet connection? Even if I'm trying to do offline tasks like type emails and texts.

    It is clearly using more today as my battery is at 30% at 7pm, while its normally around 50-60.

    I'm running the March security update as April is not yet available.

    Thanks
    04-11-17 07:07 PM
  2. Rico4you's Avatar
    I usually once a month clear cache and goes great, Then after do a 32 second reboot holding down Power button. My PRIV like this going very smooth.
    04-11-17 07:20 PM
  3. deremi's Avatar
    Also check to see if it is something you've recently installed. I've seen a couple of thread that indicated various seemingly harmless app that brings many android phones to a halt. Bad coding is bad coding even if unintentional.
    04-11-17 07:33 PM

Similar Threads

  1. Google Now/assistant calender issue
    By ranjanclandad in forum Ask a Question
    Replies: 4
    Last Post: 05-19-17, 06:57 AM
  2. Virgin UK 4G issues?
    By BobRubus in forum BlackBerry Z30
    Replies: 6
    Last Post: 04-27-17, 03:38 PM
  3. Replies: 18
    Last Post: 04-10-17, 01:16 PM
  4. Dtek60 not charging
    By Vinit Gulati in forum Ask a Question
    Replies: 5
    Last Post: 04-10-17, 03:43 AM
  5. How do I setup a 1and1 email account on BB DTEK60?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 04-09-17, 12:33 PM
LINK TO POST COPIED TO CLIPBOARD