1. CrackBerry Question's Avatar
    BB was plugged into wall charger and 3 hours later returned to see white screen. Unplugged the thing and white screen turned off...no power. Took out battery and reinstalled it. Red LED light came on for 7 seconds then went off and I get nothing. I can do nothing. I tried a hard boot, reinstalling OS5 (Computers do not even recognize device is plugged in. ONLY thing that happens is Red LED light goes on for 7 seconds and then goes off when I uninstall and reinstall battery. I'm thinking the battery just is bad. Am I on the right track?
    03-23-15 05:08 PM
  2. jope28's Avatar
    If I remember correctly...
    Try plugging it in to the wallcharger without the battery in the device. The red light should be on. Then hold down the power button while you insert the battery and keep the power button pressed until you see the charging battery icon on the center on the screen. Then release the power button and leave the device plugged in until it reboots.

    [Hopefully NOT edited by admin to be fair lol. ] Frosty White Q10/10.3.1.2582 CB10
    03-23-15 06:02 PM

Similar Threads

  1. BB Blend stops working ?
    By Warios in forum BlackBerry Q10
    Replies: 5
    Last Post: 05-12-15, 11:06 AM
  2. I'm back from iPhone 6 Plus to BB Classic
    By bglawrence in forum BlackBerry Classic
    Replies: 14
    Last Post: 03-25-15, 08:49 AM
  3. Replies: 6
    Last Post: 03-24-15, 10:51 PM
  4. Should the Classic or the Z30 be my 1st VzW BB phone?
    By CrackBerry Question in forum Ask a Question
    Replies: 6
    Last Post: 03-23-15, 08:02 PM
LINK TO POST COPIED TO CLIPBOARD