1. johari786's Avatar
    Hi all,
    Happy New year to all of u.

    I am not able to install or use BlackBerry protect on my BlackBerry Z10...my OS is upgraded one..not 10.3...still facing the same issue. When I try to install BlackBerry protect it says device not compatible.please help. Thanks in advance..

    Posted via CB10
    01-02-15 12:50 AM
  2. jaydee5799's Avatar
    Protect should already be installed on your device. Look under settings and find it.
    It really doesn't do much either. Only that you can track your phone if you lose it and play a tone. It won't backup or restore data like before. We lost that with OS 10
    01-02-15 07:43 AM
  3. JamBueree's Avatar
    BlackBerry Protect no longer has to be downloaded as a separate application as it was on legacy OS devices.
    It is not integrated into the settings.

    Cant use Blackberry Protect for my Z10-picsart_1420207273652.jpg
    Cant use Blackberry Protect for my Z10-img_20150102_215847.png

    The only downside to it is that it no longer backs up your data as it did in older devices. To back your device, you're gonna have to connect your phone to BlackBerry Link via USB -> Computer

    Miami Heat and GS Warriors fan.
    01-02-15 08:03 AM

Similar Threads

  1. BlackBerry Classic II (concept)
    By BriniaSona in forum BlackBerry Concepts & Dream Devices
    Replies: 16
    Last Post: 01-05-15, 01:47 AM
  2. How do I download the OS 10.3 leaked version for Z 10 STL100-1?
    By CrackBerry Question in forum Ask a Question
    Replies: 6
    Last Post: 01-02-15, 11:13 AM
  3. z10 slt 100-2/3
    By Shyam 97 in forum BlackBerry Z10
    Replies: 4
    Last Post: 01-02-15, 12:24 AM
LINK TO POST COPIED TO CLIPBOARD