1. CrackBerry Question's Avatar
    My blackberry 9810 is probably 5 years old. I sold it on eBay and the last time I checked quite some time ago it did work. I just tried charging it and it's not turning on.

    I have tried a few different cables, including one that has a blackberry logo. Tried in the wall and in the computer. I watched a youtube video where someone had it plugged in, took the battery out, put it back in and kept pressing the power button. I never got the charging symbol. The first time I forgot to put the battery in and I did get an imagine of a battery with a red X on it. I have seen responses to the video that there are different variations people have done.

    I went to a repair shop and they put another BB9810 battery in and the lightning symbol came on instantly - they used their charger but I'm sure it wouldn't have mattered. I've tried 2 different cables.

    Can anyone please help!?
    Thanks

    PS: What I see when I have the battery in and then try charging is red light comes on - it is solid for maybe 20 seconds. It then turns off for almost a minute. The light then comes back on and is solid for another 20 seconds then goes away.
    04-14-17 08:44 AM
  2. Dunt Dunt Dunt's Avatar
    My blackberry 9810 is probably 5 years old. I sold it on eBay and the last time I checked quite some time ago it did work. I just tried charging it and it's not turning on.

    I have tried a few different cables, including one that has a blackberry logo. Tried in the wall and in the computer. I watched a youtube video where someone had it plugged in, took the battery out, put it back in and kept pressing the power button. I never got the charging symbol. The first time I forgot to put the battery in and I did get an imagine of a battery with a red X on it. I have seen responses to the video that there are different variations people have done.

    I went to a repair shop and they put another BB9810 battery in and the lightning symbol came on instantly - they used their charger but I'm sure it wouldn't have mattered. I've tried 2 different cables.

    Can anyone please help!?
    Thanks

    PS: What I see when I have the battery in and then try charging is red light comes on - it is solid for maybe 20 seconds. It then turns off for almost a minute. The light then comes back on and is solid for another 20 seconds then goes away.
    Not clear on what happened between when it appeared the repair shop had it charging and you're still having issues. Did they keep it and see if it would keep charging or boot? Did you buy a new battery? Are you using cords and chargers that you are sure are working (tested with another device)?

    I would leave the phone with the repair shop... If they can't get it to charge enough to boot, then maybe they'll have a suggestion on fixing it or scraping it.
    04-14-17 09:00 AM
  3. liddonfew's Avatar
    I had the same with my old 9800. Found that. I had to store it with the battery out.Otherwise when wanted it would not recover. This my favourite phone of all.Try charging battery in a working one and transfer. I currently use,9800,passport&priv in that order.

    Posted via CB10
    04-24-17 01:10 AM

Similar Threads

  1. How to use WhatsApp on Q10 after June?
    By petercreasey in forum BlackBerry Q10
    Replies: 20
    Last Post: 09-09-17, 02:58 AM
  2. Replies: 5
    Last Post: 04-30-17, 04:09 AM
  3. Replies: 2
    Last Post: 04-14-17, 06:10 PM
  4. Blackberry Classic Emergency Calls Only, Technical Problem, SIM Blocked
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 04-14-17, 09:57 AM
  5. Late April release date for KeyOne on Rogers....
    By world traveler and former ceo in forum BlackBerry KEYone
    Replies: 5
    Last Post: 04-14-17, 09:18 AM
LINK TO POST COPIED TO CLIPBOARD