1. Mord3Kay's Avatar
    I have the STL100-1.
    In my friends phone both of my batteries will indicate they are fully charged at 100%. When they're in my phone they show other amounts like 61%. The tests are the same using my dad's Z10, my phone doesn't indicate the true charge.
    I have a portable charger that works great with all the Z10's I've used but on my phone it'll only charge like 50% because my phone isn't acting right.
    I'm struggling to explain my problem in English.

    This morning my battery in my phone displayed as 71% but in my dad's phone it said 88%, that's a big difference. I'm not even sure if 100% on my phone truly means 100% even.
    Is there anyway for me to fix this problem myself? I don't have a warranty anymore.

    Posted via CB10
    03-16-15 01:57 AM
  2. Mord3Kay's Avatar
    My battery life feels really bad some says, I've tried different batteries, so the problem lies with my device.

    Posted via CB10
    03-16-15 01:58 AM
  3. jafobabe's Avatar
    Have you rebooted your phone?

    Reboot and leave off for about 5 minutes.. Then Power it back on. Connect your device to a wall charger and remove battery even though it's charging, after 1 minute re insert the battery and charge for 2 -3 hours
    03-16-15 02:04 AM

Similar Threads

  1. Vote for BlackBerry Passport to win Mobile Madness 2015
    By Douken in forum BlackBerry Passport
    Replies: 61
    Last Post: 03-25-15, 08:01 AM
  2. Replies: 7
    Last Post: 03-24-15, 09:28 AM
  3. Replies: 8
    Last Post: 03-21-15, 06:36 PM
  4. Why can't I connect to BlackBerry Blend?
    By CrackBerry Question in forum BlackBerry Blend
    Replies: 1
    Last Post: 03-16-15, 01:22 AM
  5. Replies: 1
    Last Post: 03-16-15, 12:58 AM