1. Sam_mie's Avatar
    My BlackBerry z10 says turning off device at 73%. When I start to charge turns on after a while when I unplug I'm able to use it till it's 73% then it goes off again. It has gone off twice already.

    Posted via CB10
    07-11-14 02:15 AM
  2. pkcable's Avatar
    Try running this program and see if you have a hardware issue....

    BlackBerry Virtual Expert - BlackBerry World
    07-11-14 03:38 PM
  3. Sam_mie's Avatar
    No hardware issues passed all the tests

    Posted via CB10
    07-15-14 09:44 PM
  4. habs_fan's Avatar
    http://forums.crackberry.com/showthread.php?t=945137

    Sounds like your having bad luck with your BlackBerry.

    Did you purchase it through your carrier? You should try to send it in for repair

    Posted via CB10
    07-15-14 09:50 PM
  5. sejuramesh's Avatar
    This is phone problem, the phone uses to much power so the battery destroyed, now you will have to take new battery, but after some this type of problems will occurs again so give your phone to service centre for repair or it may be replaced.

    Posted via CB10
    07-15-14 11:23 PM

Similar Threads

  1. Blackberry 10 "nature" concept phone
    By propeller10 in forum BlackBerry Concepts & Dream Devices
    Replies: 28
    Last Post: 03-08-15, 09:47 PM
  2. Z10 acting weird
    By marius de guzman in forum BlackBerry Z10
    Replies: 10
    Last Post: 08-18-14, 11:12 AM
  3. Who should be BlackBerry's next Creative Director/Spokesperson?
    By Mr2KiEu in forum General BlackBerry Discussion
    Replies: 48
    Last Post: 07-15-14, 12:33 AM
  4. CBC Video : BlackBerry PASSPORT in the news!!
    By BB30000 in forum BlackBerry Passport
    Replies: 39
    Last Post: 07-14-14, 03:19 AM
  5. What percentage of BlackBerry users are on Crackberry?
    By skstrials in forum General BlackBerry Discussion
    Replies: 10
    Last Post: 07-11-14, 04:19 PM
LINK TO POST COPIED TO CLIPBOARD