1. CrackBerry Question's Avatar
    My Blackberry priv STV100-4 is not charging from orginal adaptor. I tried different charges also. If I want charging without adaptor. My phone give to me this alert : "Disconnected %50". But charge indicator is running but in the indicator dont have electricity sign. If I connected with USB. It gives " Connect" and charging. I formatted my phone also. I think maybe it's software fail. But my problem us same. Can anyone help me? How can I solve this problem. My bbm D895A164
    09-08-17 07:59 AM
  2. Dunt Dunt Dunt's Avatar
    A PC is a weak power source for charging modern phones.... do you have any older USB power blocks or chargers you could try. Maybe the circuit is damaged and won't work with higher power sources?

    You said you formatted your phone.... did you reinstall the OS? Did you try a newer version (if there is one)?
    09-08-17 02:28 PM
  3. w_yudha's Avatar
    I also got the same problem. my STV 100-1 only charge from pc and form my car usb slot. Ive tried to charge with other charger, but still not charging at all. I also ve reset my phone, and nothing happen. is it a software or hardware problem? it's so annoying cause it takes forever to charge it from pc. thank you
    10-07-17 07:21 AM
  4. ahmartinez's Avatar
    I Have the same problem, my BB Priv STV100-1 Won't charge anymore!!!

    Tried normal charger etc.. other cables etc..

    Now that the battery has drained it just goes into charge loop.. it vibrates, then red light comes on.. then red light turns off, screen shows battery empty at 0%.. and then it vibrates again and red light comes on.. and so on..

    I replaced the battery yesterday, and today I did the "Three restart/reboot methods" and still the same loop, vibration.....

    PLEASE HELP!!!!!!
    10-07-17 07:38 AM
  5. BB-JAM215's Avatar
    Your phone's software does control the charging process. Sounds like either a system update bug or perhaps and app conflict. Have installed any battery monitor related apps?
    10-07-17 09:56 AM

Similar Threads

  1. Replies: 15
    Last Post: 10-04-17, 10:37 AM
  2. Questions about KeyOne from a Bold user
    By DBJS in forum BlackBerry KEYone
    Replies: 22
    Last Post: 09-11-17, 11:27 AM
  3. Remove AT&T logo from back of KEYone Black Edition?
    By khlover520 in forum BlackBerry KEYone
    Replies: 10
    Last Post: 09-09-17, 01:21 PM
  4. blackberry assistant for DTek60?
    By Bells1612 in forum Ask Bla1ze
    Replies: 2
    Last Post: 09-08-17, 08:02 AM
  5. What are all these "com.blackberry.sensorbot, .fastdormancy...ect.?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-08-17, 07:52 AM
LINK TO POST COPIED TO CLIPBOARD