1. CrackBerry Question's Avatar
    Hi guys could someone please assist I have a blackberry playbook that I haven’t used in years when I put on charge the red light comes on after a while the battery logo come one with the lighting bolt then few second (maybe 10) a solid yellow or green light comes on. Then it begins the process all over again could someone advice me what to do
    03-03-19 10:16 AM
  2. johnny_bravo72's Avatar
    Probably needs a new battery. Good luck finding one.
    03-03-19 11:02 AM
  3. brookie229's Avatar
    Hi guys could someone please assist I have a blackberry playbook that I haven’t used in years when I put on charge the red light comes on after a while the battery logo come one with the lighting bolt then few second (maybe 10) a solid yellow or green light comes on. Then it begins the process all over again could someone advice me what to do
    Do a web search (also somewhere here on CB) for a process called Stack Charging. Try that but if it doesn't work just remember that you battery is now 7 years old (?). They don't last forever.
    03-03-19 11:03 AM
  4. TrumpetTiger's Avatar
    Hi guys could someone please assist I have a blackberry playbook that I haven’t used in years when I put on charge the red light comes on after a while the battery logo come one with the lighting bolt then few second (maybe 10) a solid yellow or green light comes on. Then it begins the process all over again could someone advice me what to do
    I'd suggest leaving it to charge for multiple days. Sometimes old PB batteries lose even the charge needed to quickly build up a greater charge. Let us know how it goes or if you need further help.
    03-05-19 04:03 PM
  5. cbvinh's Avatar
    If you're going to do the stack charging, use the original charger or just a USB cable connected to a computer. The rapid charger doesn't work for this.
    03-06-19 01:11 AM

Similar Threads

  1. BlackBerry Motion typing issue
    By drkohut in forum BlackBerry Motion
    Replies: 5
    Last Post: 03-12-19, 08:42 AM
  2. Blackberry Keyone SIM problem
    By Tass1 in forum BlackBerry KEYone
    Replies: 20
    Last Post: 03-06-19, 10:31 AM
  3. Replies: 3
    Last Post: 03-03-19, 08:47 AM
  4. Blackberry KeyOne - Blackberry Hub Draining Battery
    By linksthedog in forum BlackBerry KEYone
    Replies: 2
    Last Post: 03-02-19, 11:04 PM
  5. My settings wont open on my Blackberry 10
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 03-02-19, 08:25 PM
LINK TO POST COPIED TO CLIPBOARD