1. umar0009's Avatar
    Hello..My bb z10 just dead after two month using .
    I am using 3g and it heats up and start lagging I just restart it and take upto 15 mint to load so pulled up the battery and pulled back it but only yellow light on (led) on and after 10 mint it off.and never on completely dead no charging no usb recongnization nothing it dont show usb I am very upset Please help me
    I checked to mechanic but he dont know about fault he said it is dead
    i am from pakistan i just bought it 2 months ago this is my first smart phone now dead really sad .I m ****ed up
    No warranty nothing.no one know how to repair it
    Is there is any hope
    please give me suggestion Thank you ...oooh black berry...
    mail me at umerkhld@outlook.com
    or
    umar.khalid@ucp.edu.pk
    06-23-14 04:31 AM
  2. anischab's Avatar
    Try recharging battery or replacing it... It sound to be a power problem here... Did you start/restart the device plugged in? There are some faulty batteries out there... The battery itself is not expensive... I'd get a new one (you certainly need a second one someday, at least to swap batteries in a busy day). Even for my Q I did it. Your problem occured once in the past for me, with my Bold. I kept it a whole night charging, after having pulled the battery and it recussitated again.
    I hope you got inspired and wish you good luck in solving the issue!
    Cheers.

    BlackBerry*Q10, T-Mobile Germany - SQN100-3, Running OS 10.2.1.2941
    06-23-14 04:54 AM
  3. Uzi's Avatar
    Sounds faulty when it loading you pull out the battery
    Did you get led light when connected to pc?

    Posted via CB10
    06-23-14 05:15 AM
  4. umar0009's Avatar
    not at all
    06-23-14 05:38 AM
  5. umar0009's Avatar
    I checked the battery to mecahanic he said it is alright the problem is with phone .he try to on it by using power supply but failed no led no usb shows on pc or on laptop help me
    06-23-14 05:41 AM
  6. umar0009's Avatar
    Sounds faulty when it loading you pull out the battery
    Did you get led light when connected to pc?
    not at all

    Posted via CB10
    06-23-14 05:43 AM
  7. umar0009's Avatar
    Try recharging battery or replacing it... It sound to be a power problem here... Did you start/restart the device plugged in? There are some faulty batteries out there... The battery itself is not expensive... I'd get a new one (you certainly need a second one someday, at least to swap batteries in a busy day). Even for my Q I did it. Your problem occured once in the past for me, with my Bold. I kept it a whole night charging, after having pulled the battery and it recussitated again.
    I hope you got inspired and wish you good luck in solving the issue!
    Cheers.

    BlackBerry*Q10, T-Mobile Germany - SQN100-3, Running OS 10.2.1.2941
    I checked the battery to mecahanic he said it is alright the problem is with phone .he try to on it by using power supply but failed no led no usb shows on pc or on laptop help me
    06-23-14 05:43 AM
  8. anischab's Avatar
    I'd try to let the device at least 2h plugged into original charger. Best, recharge the battery over night. Try to get piece of mind. If the device restarts, all good. Else, it might have been wiped or so. (Then manage somehow to reinstall OS)... Don't give it up, but do not hope too much either... Good luck!

    BlackBerry*Q10, T-Mobile Germany - SQN100-3, Running OS 10.2.1.2941
    umar0009 likes this.
    06-23-14 05:53 AM
  9. Uzi's Avatar
    06-23-14 05:57 AM
  10. umar0009's Avatar
    but it does not connect to pc
    06-23-14 07:35 AM
  11. oliversdickens's Avatar
    If it's still under warranty, I would send it in for repair or replacement. If not, the first option I would test it with a different battery to be sure this is not the issue. Try borrow one from somebody who has similar phone so you don't need to buy if it's not the issue. If battery is not the issue, I suspect it could be an issue with the micro usb charging port. These can become loose from the main circuit board. These can be replaced and repaired but you need somebody who knows how to do this as it not simple. Also check the port itself, they can become clogged up with dirt which prevents the cable connecting properly, you can very carefully clean it if this is the case.

    Posted via CB10
    06-23-14 08:09 AM
  12. umar0009's Avatar
    i purchased it without warranty and it is no usb issue
    06-23-14 10:19 AM
  13. huungryshark's Avatar
    It is a known issue , charge battery with a different OS (must be lower

    RedBerry Z10 #00167 10.2.1.3175
    06-23-14 05:27 PM

Similar Threads

  1. How to downgrade Z10 to previous BB OS version ?
    By imkabil in forum Ask a Question
    Replies: 3
    Last Post: 08-15-14, 09:21 PM
  2. BB Z30 Prices in the Philippines?
    By leojzueg in forum Asia Pacific
    Replies: 5
    Last Post: 07-03-14, 06:47 PM
  3. Z10 Keyboard : Backspace Misplace!
    By Canadaace in forum BlackBerry Z10
    Replies: 15
    Last Post: 06-27-14, 02:53 AM
  4. BBM problem on Z10
    By Reza Leksmana in forum Ask a Question
    Replies: 6
    Last Post: 06-25-14, 06:05 PM
  5. Replies: 5
    Last Post: 06-23-14, 08:23 AM
LINK TO POST COPIED TO CLIPBOARD