Built for Business - Learn more about BlackBerry KEY2
  1. CrackBerry Question's Avatar
    Hi,

    Strange thing happened today.. I used my phone as usual, when suddenly the phone restarted and after that there is no cellular network connection. Small investigation which i made, shows that the phone lost imei number... And here is the question: what is the cause of this and how to repair my phone??
    10-07-19 03:19 PM
  2. Bla1ze's Avatar
    Hi,

    Strange thing happened today.. I used my phone as usual, when suddenly the phone restarted and after that there is no cellular network connection. Small investigation which i made, shows that the phone lost imei number... And here is the question: what is the cause of this and how to repair my phone??
    Not sure how a phone can lose its IMEI number but a factory reset is in order for you.
    10-07-19 04:10 PM
  3. MattSPOL's Avatar
    Hi,
    Thanks for fast answer.

    That was my last option.. I was hoping there is another way and maybe somebody else has the same problem.
    10-08-19 01:08 AM
  4. MattSPOL's Avatar
    Not sure how a phone can lose its IMEI number but a factory reset is in order for you.
    Ok. I did factory reset, but that doesn't help. Still no network.
    About the IMEI - when i type *#06# it shows me IMEI 0/12
    Phone is working under android 6.0.1 (AAW068)

    BTW. The sim card works (I tested it on a different device).
    Last edited by MattSPOL; 10-08-19 at 11:19 AM.
    10-08-19 10:21 AM
  5. MattSPOL's Avatar
    Not sure how a phone can lose its IMEI number but a factory reset is in order for you.
    I also reloaded software using this article: https://www.blackberry.com/us/en/sup...roid-os-reload
    Still no network
    Any ideas??? Or maybe I should write directly to BB Support?
    10-09-19 07:53 AM
  6. Chuck Finley69's Avatar
    I also reloaded software using this article: https://www.blackberry.com/us/en/sup...roid-os-reload
    Still no network
    Any ideas??? Or maybe I should write directly to BB Support?
    What does your carrier say? I’d start with them.
    10-09-19 09:11 AM
  7. MattSPOL's Avatar
    What does your carrier say? I’d start with them.
    The sim card works on a different device - only when I put it to the BB - there is no service.

    Moreover, according to bb support the device is valid:
    BB Priv lost network cellular connection.-bbpriv.png
    10-09-19 10:50 AM
  8. Chuck Finley69's Avatar
    The sim card works on a different device - only when I put it to the BB - there is no service.

    Moreover, according to bb support the device is valid:
    Click image for larger version. 

Name:	bbPriv.png 
Views:	6 
Size:	23.5 KB 
ID:	446408
    Great that your SIM recognizes your other IMEI with the other device. That’s also good that BB Support confirmation of valid IMEI in trouble device. I’d still go to your carrier since it could be network or security error in their system.
    10-09-19 11:10 AM
  9. MattSPOL's Avatar
    Hmm.. ok, but I also tried with other sim card (different carrier). The same result: no service in bb -> works in a second device.
    To clarify - When I put a sim to the bb and type *#06# I'm getting a message that IMEI 0/12 - that's it.
    10-09-19 11:32 AM
  10. MattSPOL's Avatar
    Hmm.. so what... no other suggestions than contact my carrier?!
    10-14-19 12:39 AM
  11. mh1983's Avatar
    Have you tried clearing the network settings? That'll reset all saved wifi networks so you'd have to reenter them. Might be worth a try.

    Posted via CB10
    10-14-19 06:39 AM
  12. MattSPOL's Avatar
    Clearing network settings didn't help. However, thanks for the suggestion.
    I started wondering, if sim card slot is been broken, it is possible?
    10-16-19 12:38 AM
  13. mh1983's Avatar
    Clearing network settings didn't help. However, thanks for the suggestion.
    I started wondering, if sim card slot is been broken, it is possible?
    It is possible. It could also have dust in it. Take out your SIM and check the slot for dust. Clean it out if needed and then reseat your SIM. The Sim could also be bad; it'd be good to test it in another phone to rule that out too.

    Posted via CB10
    10-16-19 05:29 AM
  14. MattSPOL's Avatar
    I already tested the sim. It works fine in a different device.
    10-16-19 06:07 AM

Similar Threads

  1. Google Play Store App - Night or Dark Mode on Priv.
    By Ginowine in forum BlackBerry Priv
    Replies: 13
    Last Post: 10-14-19, 04:12 PM
  2. No cable connected, but shows connected in menu.
    By Hrishikesh Jadhav in forum BlackBerry Passport
    Replies: 7
    Last Post: 10-09-19, 10:10 PM
  3. BB OS on Raspberry Pi
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-09-19, 09:35 PM
  4. Replies: 1
    Last Post: 10-08-19, 10:22 PM
  5. Why have I lost one sms message and can't get back
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-08-19, 01:04 PM
LINK TO POST COPIED TO CLIPBOARD