1. The Very Same's Avatar
    Hi there, I'm using a Q10 and am having difficulties with getting Amazon apps to update properly.

    They seem to download okay, then when it gets to the installing part they just spin their wheels (see attached picture to see what I mean). Nothing happens.

    Has anyone else had this problem? Any idea on how to fix it?

    It's VERY annoying because the Hub keeps reminding me I have some updates to install, which I am trying to but cannot!

    Amazon apps won't update properly-img_20160909_151506.png

    Posted via CB10
    09-09-16 02:25 AM
  2. jaydee5799's Avatar
    more than likely your Classic doesn't have have the acceptable android runtime to update the apps.
    09-09-16 05:30 AM
  3. The Very Same's Avatar
    Okay, thanks for letting me know. Sorry for the ignorance, but how would I get the correct Android runtime?

    Posted via CB10
    09-10-16 03:26 AM
  4. rthonpm's Avatar
    I've had issues where Amazon apps won't start to update unless wifi is turned on, even when the settings in the Amazon app allow unlimited download size over a mobile connection.

    Posted via CB10
    09-10-16 11:36 AM
  5. ohaiguise's Avatar
    Sometimes you have to let it sit for up to 30 minutes before it will actually install. Also, try a reboot and launch the Amazon Appstore again.
    09-10-16 12:38 PM
  6. The Very Same's Avatar
    Still having problems.
    I tried those suggested things (thank you!) but unfortunately I didn't have any luck.
    Any other ideas / suggestions?

    By the way I'm still not sure about an "android runtime". Does anyone know what this might mean, excusing my ignorance?

    Posted via CB10
    12-17-16 06:54 AM
  7. Lusitano17's Avatar
    Still having problems.
    I tried those suggested things (thank you!) but unfortunately I didn't have any luck.
    Any other ideas / suggestions?

    By the way I'm still not sure about an "android runtime". Does anyone know what this might mean, excusing my ignorance?

    Posted via CB10
    Read article and load the fix which it refers to.
    Reboot device after installing.

    http://support.blackberry.com/kb/art...mber=000037772

    Posted via CB10
    12-17-16 10:55 AM
  8. The Very Same's Avatar
    Thanks for the advice!

    I followed the instructions on that forum thread, but in my case it didn't work.

    HOWEVER after tinkering around a bit more I think I fixed it.

    After following that thread, I then went to the Amazon app store app, pressed the menu button, then settings, then version and release notes, and then check for updates. In this case, there was a new update available for the app store.

    After updating the amazon app store, I then tried again to update the apps I was having trouble with before. They had to re-download, but after that happened the updates all worked! Woo!

    Posted via CB10
    12-30-16 06:42 AM

Similar Threads

  1. September Security Update
    By bh7171 in forum BlackBerry DTEK50
    Replies: 67
    Last Post: 09-21-16, 02:34 AM
  2. How do I get the new lyft apk? google play services won't instal.
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 09-13-16, 05:23 PM
  3. DTEK50 Unlocked wont receive September security update
    By mgplaya in forum General BlackBerry Discussion
    Replies: 13
    Last Post: 09-12-16, 03:35 PM
  4. Tap to wake no longer works since today's app updates?
    By theMite7401 in forum BlackBerry Priv
    Replies: 6
    Last Post: 09-09-16, 12:59 AM
  5. Problems with physical keys on Microsoft apps
    By drypaint in forum BlackBerry Priv
    Replies: 1
    Last Post: 09-09-16, 12:39 AM
LINK TO POST COPIED TO CLIPBOARD