1. CrackBerry Question's Avatar
    My regular lunchtime alarm on my Blackberry Passport went off on time - but nothing showed on the screen and pressing buttons or screen failed to stop the alarm which just kept going until the phone died - and is now totally unresponsive and does not acknowledge the charger.
    Anyone got any ideas about this please?
    12-08-16 02:09 PM
  2. JuiciPatties's Avatar
    That sounds very odd. Are you able to run the BlackBerry virtual expert (BBVE) app and go through all the tests to see if there are issues? See if that detects any problems.
    12-08-16 02:24 PM
  3. byex's Avatar
    Press and hold the volume up and down keys simultaneously. See if that does anything.

    Posted via CB10
    12-08-16 02:54 PM
  4. Moffatmagic's Avatar
    Diagnostic app sounds useful but the phone is totally dead and unresponsive.
    12-08-16 03:08 PM
  5. Moffatmagic's Avatar
    I thought it was as dead as a dodo but the two button thing has woken it up - and I thought the alarm running for hours would have drained the battery but its showing at 78% and all seems well. Thanks a bunch!!!
    12-08-16 03:13 PM
  6. mad_mdx's Avatar
    It would probably takes more than 10 hours of the alarm going off to kill the battery lol. Must have just bugged out! Weird stuff

    Posted via CB10
    12-08-16 04:20 PM
  7. Halifax Guy's Avatar
    My regular lunchtime alarm on my Blackberry Passport went off on time - but nothing showed on the screen and pressing buttons or screen failed to stop the alarm which just kept going until the phone died - and is now totally unresponsive and does not acknowledge the charger.
    Anyone got any ideas about this please?
    My lunch time alarm has never killed the battery. Then again, my stomach growling is my lunchtime alarm.

    Posted using a Q10, 10.3.2.2474.
    12-08-16 08:32 PM
  8. byex's Avatar
    I thought it was as dead as a dodo but the two button thing has woken it up - and I thought the alarm running for hours would have drained the battery but its showing at 78% and all seems well. Thanks a bunch!!!
    You're welcome.

    Posted via CB10
    12-09-16 11:32 AM

Similar Threads

  1. Problems after the new update 10.3.3 on my Passport SE
    By Hazolite in forum Ask a Question
    Replies: 4
    Last Post: 01-01-17, 05:17 PM
  2. Replies: 17
    Last Post: 12-30-16, 06:20 PM
  3. An kompitishun for hall the hedifikated memerers sea eh?
    By sad_old_man in forum Rehab & Off-Topic Lounge
    Replies: 27
    Last Post: 12-13-16, 11:51 AM
  4. Proximity Sensor buggy on Passport
    By Moon_Man in forum BlackBerry Passport
    Replies: 3
    Last Post: 12-09-16, 06:38 AM
  5. 10.3.3 on AT&T
    By jfaught in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 12-08-16, 03:39 PM
LINK TO POST COPIED TO CLIPBOARD