1. sotapoppy's Avatar
    The last 2 days my emails have not been pushed. I only receive email when I open the mail application. I'm receiving my emails immediately on my blackberry 8900 from the same Yahoo account and this was the case until 2 days ago with my iphone 3gs.

    I deleted and re-added the yahoo account but still no push. I also reset the iphone with no change. Other push notifications are working fine, i.e. IM+ for AIM and Yahoo IM.

    What am I missing?
    06-30-09 12:04 AM
  2. charliej66's Avatar
    You'll have that happen a lot. Yahoo push (email to iPhone) is very unreliable. Sometimes it slow, or just doesn't work. But, it's free.
    07-02-09 02:23 PM
  3. cobra302's Avatar
    i agree with charlie, i've got a free yahoo acct that pushes only when it feels like it. with a blackberry, it works a little bit different in that the email is pushed to you by the bis servers. with the iphone, yahoo pushes straight to you. at least this is how i understand it to work. i just signed up for the 60 day free mobile me trial, and it seems to be working really well. push is very quick. not quite as fast as my berry i dont think, but pretty quick. of course, now, i cant forward my yahoo email to the me acct because it wants me to upgrade to plus for that. *sigh* oh well, gmail is working this way and that makes me happy.
    07-03-09 01:44 AM
  4. sotapoppy's Avatar
    Well it started working again and for the last day or so the speed is actually equal to my 8900. BTW I'm using Yahoo mail plus.
    07-03-09 01:09 PM
LINK TO POST COPIED TO CLIPBOARD