1. Username00089's Avatar
    Credit goes to the iPhone Blog for this:

    Many users who jailbroke their iPhone with blackra1n and then used blacksn0w to unlock their iPhone faced issues such as YouTube not working, WiFi not connecting to any hotspot and other GPS related issues. Well luckily a fix has been rolled out that solves the above mentioned problems.

    Using the updated version of Push Fix, users can be rest assured to get rid of issues such as YouTube not working , WiFi not connecting to hotspots.

    Listed below are the steps to install Push Fix and YouTube from Cydia, and get rid of the issues that occurred after jailbreaking iPhone 3G/ iPhone 3GS with iPhone OS 3.1.2 using blackra1n.

    How to : Install Push Fix and YouTube from Cydia

    1. Open Cydia on your iPhone
    2. Tap the Manage Tab on the bottom of the screen, and then click on Sources.

    3. Press the Edit Button at the top right of the Sources screen and then click Add button at the top left of the screen.

    4. It will prompt you to enter a URL. Type http://cydia.iphoneil.net and then tap the Add Source button.

    5. Press the Return to Cydia button. and then Done button at the top right of the Sources screen.

    6. Move to search Tab, and enter Search Fix as the search query. Once the Push Fix and Youtube appears in the search results, tap it and then tap the Install button on the resultant screen.

    7. It will ask you for confirmation. Press the Confirm button to start installing the fix.

    8. Once the installation is completed, A Complete screen will appear. Press the Reboot Device button.

    After you restart your iPhone, all the YouTube, WiFi and other GPS related issues would have been resolved will no longer be visible.
    Last edited by forever29; 12-03-09 at 04:54 PM.
    12-02-09 05:53 PM
  2. mofoahh's Avatar
    great to know. thanks.
    12-29-09 12:58 PM
  3. Username00089's Avatar
    You know I have to say I've installed this but to tell you the truth it hasn't helped
    a whole lot.
    12-30-09 01:07 PM
  4. mofoahh's Avatar
    Yes i kno i've seen some of your posts with your network issues. LOL
    01-05-10 12:34 PM
  5. Username00089's Avatar
    I just finally restored and re-jailbroke. Those issues are finally gone.

    You know what's funny though is that I can't even find that fix in Cydia anymore.
    I told someone about this thread and she told me that when she went through
    the steps the fix wasn't there anymore....
    01-07-10 01:18 PM
  6. phone_eye's Avatar
    If you have an issue with the wifi not working just reset the network settings and it'll be fine afterwards, you may have to put the apn back in once it reboots

    Posted from my CrackBerry at wapforums.crackberry.com
    01-09-10 03:00 PM
LINK TO POST COPIED TO CLIPBOARD