1. fishaddict's Avatar
    I have noticed lately that my emails have not been pushed through, I have only been able to get them if I go into my email. I even checked the email settings and it is set on push so I am not sure what is going on. If it matters, I use yahoo mail.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-27-09 11:49 PM
  2. walds11's Avatar
    I use yahoo email as well and have the same issue once in a while. A quick restart of the device usually fixes the problem. It does not happen enough for me to throw my iPhone out the window, but it is annoying. I wonder if it is an iPhone or yahoo issue?
    10-28-09 02:09 AM
  3. anon(153966)'s Avatar
    Gmail might be the best PUSH option, besides Mobile ME.
    10-28-09 07:18 AM
  4. dknyberry's Avatar
    This happens to me sometimes too. Pull out your SIM card, and do a hard reset (ie. press the home button and sleep button at the same time until you see the "slide to shut down" prompt...don't slide, but instead keep holding the two buttons down till it shuts down). Then, slide the SIM back in and turn the phone back on by pressing the sleep button. That should temporarily fix it. I wish either Yahoo or Apple would patch this problem. It is annoying.
    Last edited by dknyberry; 10-28-09 at 08:34 AM.
    10-28-09 08:28 AM
  5. scorpiodsu's Avatar
    I've had problems here and there with yahoo as well. But it seems to fix itself. I shut down my phone everynight so I it varies. Hasn't happen in a while now. Apple does need to release something to make sure this stuff doesn't happen.
    10-28-09 01:04 PM
LINK TO POST COPIED TO CLIPBOARD