04-13-10 03:21 AM
26 12
tools
  1. Garys11's Avatar
    I just saw on Demonoid.com someone has posted what he claims to be a Beta 4.0 for the G3
    I am sure it is not but just wanted to warn people to be careful if you do get it and install it...
    04-08-10 03:42 PM
  2. flyawaymike's Avatar
    I just saw on Demonoid.com someone has posted what he claims to be a Beta 4.0 for the G3
    I am sure it is not but just wanted to warn people to be careful if you do get it and install it...
    Yes, I'm running 4.0 now too, the beta is available today to developers and beta testers of the developers.

    Your phone needs to be registered with the developers account (we get up to 100), so don't attempt to install the beta file if you're not registered or you'll effectively brick your phone.
    04-08-10 07:54 PM
  3. Entertainment72's Avatar
    iPhone OS 4.0 is very buggy! more like OS 4.0 ALPHA...
    04-08-10 07:59 PM
  4. flyawaymike's Avatar
    iPhone OS 4.0 is very buggy! more like OS 4.0 ALPHA...
    I haven't experienced any issues yet, what have you come across?
    04-08-10 08:06 PM
  5. tmp3150's Avatar
    Since you can register 100 phones, can I register mine on your account? Just asking. Id love to try the beta.

    Just curios.


    Yes, I'm running 4.0 now too, the beta is available today to developers and beta testers of the developers.

    Your phone needs to be registered with the developers account (we get up to 100), so don't attempt to install the beta file if you're not registered or you'll effectively brick your phone.
    04-08-10 08:16 PM
  6. flyawaymike's Avatar
    Since you can register 100 phones, can I register mine on your account? Just asking. Id love to try the beta.

    Just curios.
    PM sent, will need your phone's UDID number.
    04-08-10 09:05 PM
  7. Garys11's Avatar
    Will you loose your jailbreak or unlock using this?
    Besides multi-tasking, what other improvements have anyone came across?
    04-08-10 10:54 PM
  8. TWISM's Avatar
    Yes, I'm running 4.0 now too, the beta is available today to developers and beta testers of the developers.

    Your phone needs to be registered with the developers account (we get up to 100), so don't attempt to install the beta file if you're not registered or you'll effectively brick your phone.
    So jealous man. Wish I had a developer account. How do you like it so far?
    04-08-10 10:55 PM
  9. mitchell209's Avatar
    iPhone OS 4.0 is very buggy! more like OS 4.0 ALPHA...
    I have it and it's working great. You can definitely tell it's a Beta 1 though.
    04-08-10 11:02 PM
  10. mitchell209's Avatar
    Will you loose your jailbreak or unlock using this?
    Besides multi-tasking, what other improvements have anyone came across?
    • Search from Google/Wikipedia in Spotlight.
    • Folders
    • Background
    • New dock
    • new icons
    • HORRENDOUS Calculator icon
    • underlines misspelled words in red
    04-08-10 11:05 PM
  11. ragnarokx's Avatar
    I would dl 4.0 if it didn't exclude my ipod 2G from multitasking

    Posted from my CrackBerry at wapforums.crackberry.com
    04-09-10 01:43 AM
  12. Speedv1's Avatar
    I would dl 4.0 if it didn't exclude my ipod 2G from multitasking

    Posted from my CrackBerry at wapforums.crackberry.com
    It's not up to it. Even the 3g is excluded due to the lack of processor demands.
    04-09-10 04:59 PM
  13. ragnarokx's Avatar
    It's not up to it. Even the 3g is excluded due to the lack of processor demands.
    I know, but I'm bummed I won't see 4.0 in it's full glory until I get an iPod 4G. It is for the best though, Apple know's what they're doing - the more universally compatible the software the worse it gets and vice versa. Following in Snow Leopard's footsteps.
    Last edited by ragnarokx; 04-09-10 at 11:21 PM.
    04-09-10 11:07 PM
  14. mitchell209's Avatar
    I know, but I'm bummed I won't see 4.0 in it's full glory until I get an iPod 4G. It is for the best though, Apple know's what they're doing - the more universally compatible the software the worse it gets and vice versa. Following in Snow Leopard's footsteps.
    They just want more people to upgrade from their first gen devices.

    I believe some people have managed to change a .plist file to enable multitasking on their iPod touch 2g, so you'll just have to wait until there is a jailbreak so you can SSH into your iPod.
    04-10-10 12:04 AM
  15. stuaw11's Avatar
    I wouldnt go that far, there are hardware limitations.

    The 1st gen devices and 2nd gen/iphone 3G only still only have a 412mhz processor and 128mb of RAM

    While the 3rd gen/3GS has a 600mhz processor and 256mb RAM

    To say that its not hardware related is a little off base. Im sure they want people to upgrade their older devices too, but Id be shocked if it wasnt a hardware limitation too.

    There's also a HUGE difference between being physically able to (through jailbreak/backgrounder) and Apple releasing it to the public where it must work flawlessly. They probably just want people to be satisfied with their phones and not bogged down on the lower RAM devices, even if it is possible through jailbreak, thats not a stable consumer solution either.
    04-10-10 12:13 AM
  16. mitchell209's Avatar
    Exactly, but the first gen iPhone and iPod have the same hardware as the 3G. There's no difference. Apple could have easily given them the 4.0 update with the same limitations as the 2G iPod and iPhone 3G.
    04-10-10 01:05 AM
  17. stuaw11's Avatar
    True but there's only so long you can expect them to officially support "legacy" devices.

    A "normal" device (99% of the other phones carriers sell) are usually EOL (end of life) within about 12-16 months of being out and no longer supported officially by the manufacturer, let alone going on 3 years. I think Apple has been MORE than supportive of the 2G giving it all the 3.x updates too, considering most phones are EOL by the time 3.0 and beyond came out.

    I have a feeling there arent a terrible amount of iphone 2Gs in use anymore anyways.
    Last edited by stuaw11; 04-10-10 at 01:16 AM.
    04-10-10 01:12 AM
  18. mitchell209's Avatar
    True but there's only so long you can expect them to officially support "legacy" devices.

    A "normal" device (99% of the other phones carriers sell) are usually EOL (end of life) within about 12-16 months of being out and no longer supported officially by the manufacturer, let alone going on 3 years. I think Apple has been MORE than supportive of the 2G giving it all the 3.x updates too, considering most phones are EOL by the time 3.0 and beyond came out.

    I have a feeling there arent a terrible amount of iphone 2Gs in use anymore anyways.
    True. I'm expecting Apple to kill off the iPhone 3G and iPod touch 2G next year. :\
    04-10-10 02:29 AM
  19. Garys11's Avatar
    I have a feeling there arent a terrible amount of iphone 2Gs in use anymore anyways.
    I have to disagree with you my friend.
    The G2's are still in demand here.
    At least here in Romania the G2 is still very in use.
    Our carriers here do not support G3 network and the GPS here sucks too, another reason is that the
    G2 can be unlocked easier even with the upgrades. I had a 2 G3's and 1 G2 for sell
    (all 3 unlocked/jailbroken), sold the G2 before I sold the G3's and for more then what I was asking for the G3's...
    I guess it is all about where you live in the world.
    04-10-10 08:34 AM
  20. mofoahh's Avatar
    agree. 2g in my opinion is better to handle and has a good feel. But the 3g is easier in terms of replacing parts.
    04-11-10 12:46 PM
  21. MaxdMerc's Avatar
    I've downloaded OS4 but i'm not going to try it yet.

    Heard so much about needing a registration to be able to use it that it's not worth taking the chance.

    I love all the Beta's on my Storm 2, I miss that on the iPhone.

    The summer can't come soon enough.....
    04-12-10 04:20 PM
  22. stuaw11's Avatar
    The beta needs to be on a developer account or your brick your phone. Its also still very beta, and beta's usually come out every other week- its not worth installing at this point. Release is only 10-12 weeks away, its already mid April.
    04-12-10 05:06 PM
  23. MaxdMerc's Avatar
    Plus the .dmg file I have is for a MAC and I don't have one.... Lol
    04-12-10 05:37 PM
  24. Garys11's Avatar
    The beta can not even install unless you have a Developers Account and at the same site I saw the beta on,
    the posters were selling spots anywhere from 5$-20$.
    The moderators got tried of it and stopped it. Of what I have heard it is a early
    beta, not even worth the risk. Most everything OS4 has, we can already get if
    your phone is jailbroken. I rather wait until the official release and os 4 jailbreak...
    04-12-10 07:37 PM
  25. mitchell209's Avatar
    I love using beta software. It lets me try out some of the new features before anybody else.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-12-10 10:43 PM
26 12
LINK TO POST COPIED TO CLIPBOARD