1. ladybold's Avatar
    Something weird happened today - whenever I try to Twitter, I get a message stating something like my account info is wrong and that I can't Twitter.

    So I removed all my accounts and tried to readd them and it keeps stating that I have to wrong password...which is not true, because I never changed my password and it's still the same on the account (I checked via computer).

    Is anyone experiencing the same problem?

    The official app just isn't working right now. Could it be a problem on their side>
    11-18-10 01:31 PM
  2. GolfnCPA's Avatar
    I wish I could offer you some assistance here, ladybold, but can only offer you the following: Twitter for iPhone was a problematic app for me as well. It seems like every time there is an update, something busts in it.

    I switched to Echofon two months ago and won't go back to the official Twitter app. Don't think you lose any real functionality at all by not using the official app.

    Also suggest you look at HootSuite and Tweetdeck.
    11-18-10 02:21 PM
  3. anon(153966)'s Avatar
    I suggest you log into your Twitter account via a PC\MAC, and possibly reset the credentials.

    Then, if that works, uninstall the app, reboot your device, and then reinstall, etc, etc.
    11-18-10 03:12 PM
LINK TO POST COPIED TO CLIPBOARD