1. RegE's Avatar
    Last night, I accessed my Gmail to create a filter, and I found hundreds of messages from the last week or so in my ALL MAIL that I deleted from my phone and should have been in the TRASH. It took me forever to straighten out the mess.

    I have an iPhone 4 on Verizon with a Gmail account through MS Exchange. When I delete a message on the phone, it removes it from the phone and Gmail's INBOX but does not place it in Gmail's TRASH - it remains in Gmail's ALL MAIL. Also, I noticed that if I MOVE the message (on the phone) to Gmail's TRASH, it still does not go into the TRASH - it remains in Gmail's ALL MAIL.

    As it stands now, everyday when I get home, I have to go into my Gmail account; go into my ALL MAIL and delete (move to trash) all the messages that I deleted from my phone.

    Does anyone know how to delete a message from the phone and have it go straight into the TRASH like it does on my PC?

    Other than this issue, everything else seems to be working just fine.
    02-22-11 11:29 AM
  2. occfan's Avatar
    open settings ,then mail contacts calender, then gmail, then turn off archive messages!! that should do it !!
    pilsbury likes this.
    02-22-11 12:56 PM
  3. RegE's Avatar
    Thanks for the quick response!

    When I setup my email, I only Gmail in my settings and I had that option. When I learned about using MS Exchange for true push, I installed MS Exchange; however, I then had two accounts giving me duplicate emails. I then elected to delete the Gmail and keep the MS Exchange.

    The MS Exchange provides me with the same utility/service as Gmail; however, I no longer have the option in settings for archive as you mentioned. Now that you mention it, I guess the phone is acting as though it's archiving my messages. Wish I could get MS Exchange to delete rather than archive.
    02-22-11 01:34 PM
LINK TO POST COPIED TO CLIPBOARD