1. Coler's Avatar
    Guys, I'm a lurker on this excellent forum. I'm really hoping someone out there can help me with this 16GB iPhone 3Gs which is brand new out of the box. I've tried everything I could find online by way of suggested solutions.


    Here's what happened :

    I plugged it into the wall socket to charge. It showed a red lightning flash thing and said it needed a sim charge to activate the phone. I unplugged, inserted sim card.

    Since then it has been completely dead.

    Here's what I have tried :

    Hold home & power buttons for 15 plus (say 30) seconds (in fact 2 minutes), while plugged to wall socket and while not.

    Connect to mac using USB. Do as above. Restart Mac while phone connected by USB. Turn Mac Off, Turn Mac On Again while phone connected by USB.

    Open iTunes (latest version installed), hold home & power button etc., while phone connected by USB.

    Run installer update on mac for general updates etc. Repeat all of the above.

    Disconnect phone from USB, hold home button, re-connect phone to USB.

    Frustratingly, it seems the phone is a brick. Vodafone will collect tomorrow (unless someone on here can suggest anything else further to what I've tried that is).

    I must be quite unlucky as the last phone I got from Vodafone (BB 9000) had to be replaced as well.

    What I hate is that Vodafone won't just put a new one in the post. They insist they must try and see what the fault is. It will take 'a few days' before I am sent a new phone. I'm not impressed (with Vodafone that is).

    Any thing else I can try ?
    Last edited by Coler; 07-13-10 at 10:55 AM.
    07-13-10 10:37 AM
  2. markhunsaker's Avatar
    Return it...?
    07-13-10 10:46 AM
  3. Coler's Avatar
    Yeah. Organising it now. Sucky.
    07-13-10 10:57 AM
LINK TO POST COPIED TO CLIPBOARD