1. jacobfr's Avatar
    Does any one know how to fix it. Am having wifi problems it connects to my wifi but when ever am watching a Video or just browsing the web it disconnects by it self. Any one know how to get it fix?
    12-12-09 11:44 AM
  2. dhendriksen's Avatar
    My WiFi works great. Do you have a strong signal?
    12-12-09 12:05 PM
  3. jacobfr's Avatar
    yeah i have comcast and even if i stay next to the router it still disconnects
    12-12-09 01:03 PM
  4. dhendriksen's Avatar
    I'd bet you've got an IP issue. Do you have any devices assigned a static IP that is within the DHCP range?

    What make and model is the router?
    12-12-09 08:08 PM
  5. sjsjr's Avatar
    I don't know if you have the Wifi problem worked out or not but I'll throw my .02 in. Do you have any other devices running on your wireless network? The only reason I ask is because my router had a glitch in the previous firmware that would drop computers randomly from the wireless half of the network. I could see full signal but it would not stay connected. Once I updated the firmware in the router itself I was fine. The only reason I mention it is because I went through several wireless network cards and a lot of driver changes before I figured it out. The router was a Dlink.
    12-13-09 08:53 AM
  6. jacobfr's Avatar
    I'd bet you've got an IP issue. Do you have any devices assigned a static IP that is within the DHCP range?

    What make and model is the router?
    I have my loptop but when am using my droid I don't use my loptop and on my loptop I have no issues. Just with my droid

    Posted from my CrackBerry at wapforums.crackberry.com
    12-13-09 10:31 AM
  7. timhow's Avatar
    You might want to change your security settings for your router. I had a similar issue. My laptop would work fine, but my previous Nokia and then the Droid would connect but not do much of anything afterwards.

    I changed my security settings for my router to WPA-PSK[TKIP] + WPA2-PSK[AES], and now everything works as it should. If your router doesn't have this setting, I would play with the settings you do have. Hopefully one will work.

    By the way, the router was originally set to only WEP when I had the connection problems.
    12-13-09 11:09 AM
LINK TO POST COPIED TO CLIPBOARD