Built for Business - Learn more about BlackBerry KEY2
11-26-17 12:47 PM
632 123 ...
tools
  1. tatail's Avatar
    Hi Guys,

    Some of you may know that I drive for Lyft and Uber and have been patching the apps to keep them running on my Passport.
    I saw a few threads being created relating to these apps, and I thought I should create one with proper instructions and updated patched files.

    In the link below you will find patched files for Lyft, Uber, Google Play Services and other essential apps.

    Currently my Passport is running OS 10.3.2.2530 which is the latest leak. I don't know if this will work for your version of OS.

    It might or it might not work for you, I can't guarantee..

    I am not a developer or a coder, I am just another forum member who follows instructions.
    That being said here is a few picture proof of Lyft working.

    If you have a question please do ask I'll try my best to help.

    As per Cobalt's request I am removing his apps from Box folder and I am adding a direct link to his thread and post. Please follow his instructions.

    http://forums.crackberry.com/android.../#post10933307

    From the above link Download and:
    Install Google Account Manager and login
    Install Blackberry Google ID and checkin
    Install Google Play Sevices (wait 5 minutes after you installed and let the app settle)
    Remove any unpatched version of the apps from your device if you have previously installed
    Install the patched apps you want from the link below

    ---------------------------------------
    Link for Patched APKs
    ---------------------------------------

    https://app.box.com/s/rc7k9f96wcbbn7hj3xr6bqfmmtfg8y9l
    Alternate link thanks to @sg701
    https://app.box.com/s/5k3rf55wt76qaifs5flsvmcgolpk80x7

    GetTaxi
    Wheely
    Lyft
    Uber Driver
    Uber Cab
    TaxiForSure
    Ola Cabs
    Sidecar Drive
    Google Maps

    Note:If you are having issue such as Unable to determine location do the following:
    Uninstall everything
    Restart your phone
    Install Google Play Service
    Restart your phone
    Let your phone sit idle for at least five minutes<< This is very important
    Install Google Maps
    Check if it detects your location
    If successful install Uber apps
    You should not have anymore issues.



    Working Latest Patched Lyft, Uber Partner, and Uber App-img_20150422_020043.jpg

    Working Latest Patched Lyft, Uber Partner, and Uber App-img_20150422_020024.jpg
    Last edited by tatail; 12-14-15 at 08:28 PM. Reason: Lyft, Uber Cab, Uber Driver and Sidecar driver updated
    04-22-15 04:14 AM
  2. Pluto is a planet's Avatar
    Wow thanks so much for these!! I'll confirm that all your patched apk's work (didn't try driver) on a recentish 10.3.1 Q10 build. Can't remember which one at the moment, but at least other people will know you don't need to be on 3.2 for these to work.
    04-22-15 06:28 AM
  3. tatail's Avatar
    Uber Partner app updated to v3.33.0 available using the same link..
    Larry Lapidus likes this.
    04-30-15 12:06 AM
  4. abran770's Avatar
    Thanks so much for these!!! The Uber Driver app works great on my Z10. If you don't mind, would you share the instructions you used to patch the Google Play Services apk? I've read a ton of forums and can't find that information.

    Thanks!
    05-04-15 01:53 PM
  5. tatail's Avatar
    Actually there is no instructions for it..

    All I have used was Cobalt's GMAPS Patcher..
    But there many different copies of same version Google Services for different devices. You have to find the correct version for BlackBerry 10 devices.

    Good luck.

    Posted via CB10
    Last edited by tatail; 09-23-15 at 03:38 AM.
    05-04-15 02:51 PM
  6. tatail's Avatar
    Updated latest Lyft apk (2.22.0) updated and available.
    05-06-15 02:28 PM
  7. hakdaddy1's Avatar
    Uber not working for me sadly, force closing after trying to login on Z30STA100-2/10.3.2.500 :-(

    Posted via CB10
    05-07-15 02:18 PM
  8. tatail's Avatar
    Uber not working for me sadly, force closing after trying to login on Z30STA100-2/10.3.2.500 :-(

    Posted via CB10
    Sorry to hear that.. I got a new update.. check the link on the first post..
    I stopped using Uber for the past two weeks because it is just a garbage company (strictly my personal opinion) always problem..
    Rob Perozak likes this.
    05-14-15 10:35 PM
  9. MrDigan's Avatar
    So I installed the Lyft one, and I'm getting "Unfortunately, Lyft has stopped" error and it closes automatically on me. I tried it with each of the lyft apks you provided (uninstalled one before the installing the other)

    Edit:Restarting phone worked with the latest one Problem solved
    pavanbhokray likes this.
    05-15-15 05:24 PM
  10. tatail's Avatar
    Glad to hear it finally worked for you.
    Bear in mind to use the version of Google Play Services has to be the version in the same link.

    Right now I am running 10.3.2 and it runs buttery smooth..
    The only time I get error is when my phone loses Internet connection.

    Posted via CB10
    05-16-15 12:14 AM
  11. tatail's Avatar
    Updated to:
    Lyft v2.25.0
    Uber Cab v3.50.3
    Uber Driver v3.36.1
    05-21-15 08:55 PM
  12. Prince Lem's Avatar
    please help i am new to blackberry
    I got a z10 and am trying to get the uber driver app to work but i keep getting " unable to determine location"
    what am i missing? i downloaded Uber Driver v3.36.1 and the Google Play Services version 7.0.99.
    05-22-15 09:46 AM
  13. alaviss's Avatar
    please help i am new to blackberry
    I got a z10 and am trying to get the uber driver app to work but i keep getting " unable to determine location"
    what am i missing? i downloaded Uber Driver v3.36.1 and the Google Play Services version 7.0.99.
    Have you turned Location Services on?

    Z10STL100-1/10.3.2.500
    05-22-15 11:42 AM
  14. Prince Lem's Avatar
    yes, that was the first thing I checked. anything else i may be able to do.
    05-22-15 01:53 PM
  15. Prince Lem's Avatar
    i think i have the same phone as you, z10 stl100-3
    can you run uber partner?
    05-22-15 02:31 PM
  16. tatail's Avatar
    what Operating System are you running?
    Also, if possible can you install Google Maps and check whether it gets the location or not..
    05-22-15 07:27 PM
  17. arkenoi's Avatar
    I've seen 'cannot determine location' problem several times. Don't know why, seems that location services work differently on BlackBerry and if gps satellites are not available, location fix sometimes -- not always! fails completely. Go to a window, it might help.

    Posted via CB10
    05-23-15 03:49 AM
  18. tatail's Avatar
    I also get location unavailable now and then but I give it some time and it works.

    Posted via CB10
    05-23-15 06:08 AM
  19. u_hero's Avatar
    I have the same issue "unable to determine your location" while i turn on location, have google service and gmaps with correct location already. I use 10.3.2.500 - Z10 004 Verizon.
    05-25-15 08:32 PM
  20. u_hero's Avatar
    Working Latest Patched Lyft, Uber Partner, and Uber App-img_20150526_080421.png

    Posted via CB10
    05-25-15 08:39 PM
  21. tatail's Avatar
    Give it a little time and it'll start working.. it does for me.

    Posted via CB10
    u_hero likes this.
    05-26-15 08:29 AM
  22. u_hero's Avatar
    It's not work w me after 30' waiting. Thanks anyway Tatail.
    05-27-15 03:30 AM
  23. tatail's Avatar
    Really? Can you do something install the latest version of Google Maps and check if it finds your location..

    Also, turn on your WiFi for a few minutes then open the app. You don't have to connect to a network, just turning it on works.

    Posted via CB10
    05-27-15 11:33 AM
  24. u_hero's Avatar
    Hi Tatail, i have GMaps latest version already and use wifi too. But Uber app just stop at the starting screen, and Uber partner still "unable to determine...".

    I'm a Uber driver and my Z10 does'n run Uber apps make me sad a little bit. I have to use Ipad to work on the way.

    Waiting for new update of 10.3.2 can fix that issue maybe...
    Posted via CB10
    05-28-15 11:16 PM
  25. tatail's Avatar
    Alright, give me some detail about your phone.

    What version of BB10 do you have running?
    Did you install the patched version of Google Play Services that I have linked in the first post?
    Also, I just uploaded a new version of Uber Partner download that and try again.

    Good luck.

    Posted via CB10
    05-28-15 11:30 PM
632 123 ...

Similar Threads

  1. App review thread
    By rodney0905 in forum BlackBerry 10 Apps
    Replies: 17
    Last Post: 04-25-15, 03:00 PM
  2. Question about email on both, Classic and Passport
    By luigieagle in forum BlackBerry Classic
    Replies: 10
    Last Post: 04-24-15, 04:48 AM
  3. How can I fix app error 552 on my BlackBerry?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 04-22-15, 02:02 PM
  4. Amazon Fire TV remote app.
    By artlu629 in forum Android Apps (Amazon Store & APK Files)
    Replies: 1
    Last Post: 04-22-15, 11:05 AM
  5. How to use hindi font for reading and writing on blackberry curve 8520
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 04-22-15, 02:05 AM
LINK TO POST COPIED TO CLIPBOARD