Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 4 1234 LastLast
Results 1 to 25 of 98
Like Tree5Likes
  1. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #1  

    Default Compass issue....still!!

    So I've been on a compass kick for months now. I have a few apps both paid and free that I can't use because the compass is never correct, no matter what!
    I've tried 2 replacement Z10's, called VZ, called BBRY, emailed both companies, BBRY numerous times. There are some others with the same issue and the majority seems to be those on VZ. I'm curious how many people on VZ have a properly working compass or if it's just a few affected devices here and there and all my replacement happen to be from those few. Even the most recent update doesn't fix it.
  2. pastorbrad's Avatar
    CrackBerry Addict

    Posts
    602 Posts
    #2  

    Default

    I never thought of it before and so I looked. Compass has my lat/lon location correct but does appear 45 degrees or so off. Curious

    Posted via CB10
  3. AnimalPak200's Avatar
    CrackBerry Genius

    Posts
    4,505 Posts
    #3  

    Default

    Same here, my compass is always off and claims "interference" even when I'm in the middle of nowhere without any other electronic /magnetic sources nearby (aside from nominal environmental ones of course).

    I never really use it so it doesn't bother me too much, but I agree that it's been unpredictably off for a long time.

    Posted via CB10
  4. The_Stranger's Avatar
    CrackBerry User

    Posts
    43 Posts
    #4  

    Default

    Working for me!

    Took a screenshot.
    http://imgur.com/2lhConL
    Posted via CB10
  5. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #5  

    Default

    Quote Originally Posted by The_Stranger View Post
    Working for me!

    Took a screenshot.
    imgur: the simple image sharer
    Posted via CB10
    I was hoping to be onto something until Stranger chimed in!! JK.. But seriously, Stranger I assume you are updated to the most recent OS. I think my compass worked out of the box, but soon after it stopped calibrating. I don't know what it could be??

    EDIT: Stanger, I noticed you have a Q listed as your device,, this could be isolated to Z's only.
    Last edited by jelp2; 03-20-2014 at 04:52 PM.
  6. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #6  

    Default

    Quote Originally Posted by pastorbrad View Post
    I never thought of it before and so I looked. Compass has my lat/lon location correct but does appear 45 degrees or so off. Curious

    Posted via CB10
    That doesn't make sense to me. Mine is the same. Lat and Long both show correctly and GPS points North. I wish Star Tracker could work off of GPS.
  7. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #7  

    Default

    Quote Originally Posted by AnimalPak200 View Post
    Same here, my compass is always off and claims "interference" even when I'm in the middle of nowhere without any other electronic /magnetic sources nearby (aside from nominal environmental ones of course).

    I never really use it so it doesn't bother me too much, but I agree that it's been unpredictably off for a long time.

    Posted via CB10
    I don't use the compass itself, but a few apps I have need it, so it renders the apps useless.
  8. i_hiker's Avatar
    CrackBerry Master

    Posts
    1,329 Posts
    #8  

    Default

    The compass sucks!!! That's all there is to it!!! I don't use any apps that need it, and if I need a compass I've got a nice vintage Superior Magneto compass that travels with me on the trail.
    8330>9630>9650>(skipped OS7)>VZW Z10 on 10.2.1.3253
  9. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #9  

    Default

    Quote Originally Posted by i_hiker View Post
    The compass sucks!!! That's all there is to it!!! I don't use any apps that need it, and if I need a compass I've got a nice vintage Superior Magneto compass that travels with me on the trail.
    I agree it's awful, completely useless especially since North points everywhere but!
  10. pastorbrad's Avatar
    CrackBerry Addict

    Posts
    602 Posts
    #10  

    Default

    Jelp2 what I was trying to convey is that if I point in a heading I know from other sources to be due W the compass tells me I am facing NW and so on

    Posted via CB10
  11. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #11  

    Default

    Quote Originally Posted by pastorbrad View Post
    Jelp2 what I was trying to convey is that if I point in a heading I know from other sources to be due W the compass tells me I am facing NW and so on

    Posted via CB10
    I understand. Mine is not even that consistent. It fluctuates all over. Even though yours is showing a steady 45 degree difference it should be more accurate than that. Again, I remember it working well, within a degree or so accurate, but not after an update I think last summer.
  12. LibertarianFreethinker's Avatar
    CrackBerry User

    Posts
    64 Posts
    #12  

    Default

    Same problem here with my z10 stl100-4 on Verizon. Problem started when I upgraded to os 1925. I was hoping os 2174 would fix the issue, but unfortunately this is not the case.

    Posted via CB10

    Posted via CB10
    ***I strive for the forbidden.
    ***I search for the forbidden.
    ***I hunt for the forbidden.
  13. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #13  

    Default

    Quote Originally Posted by LibertarianFreethinker View Post
    Same problem here with my z10 stl100-4 on Verizon. Problem started when I upgraded to os 1925. I was hoping os 2174 would fix the issue, but unfortunately this is not the case.

    Posted via CB10

    Posted via CB10
    I've tried loading older compass .bars but nothing worked. On one of my replacements, I tried the compass and it worked right out of the box. So that was whatever OS it was shipped with when first released. Then upgraded to the newest OS an WHAMO, the compass didn't work.
  14. zhanezeng's Avatar
    CrackBerry User

    Posts
    26 Posts
    Global Posts
    46 Global Posts
    #14  

    Default

    Sorry to hear the pain...I do not use compass a lot.. wondering how you calibrate it? Use another physical one?
  15. Dave Bourque's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,391 Posts
    #15  

    Default

    How are you testing the results ? Are you also using a flat surface ?

    Z10STL100-3/10.2.1.2141
  16. Dave Bourque's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,391 Posts
    #16  

    Default

    Have you tried gadget box ?

    Z10STL100-3/10.2.1.2141
  17. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #17  

    Default

    There's nothing really to test. It doesn't work no matter what. I could lay it flat on a table and it "cycles" interference. I can be in the middle of the yard with zero metal and it won't work.
  18. Dave Bourque's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,391 Posts
    #18  

    Default

    Quote Originally Posted by jelp2 View Post
    There's nothing really to test. It doesn't work no matter what. I could lay it flat on a table and it "cycles" interference. I can be in the middle of the yard with zero metal and it won't work.
    Did you update the app? Did you try to do the motion it tells ya to do to clear the interference.

    Z10STL100-3/10.2.1.2141
  19. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #19  

    Default

    Quote Originally Posted by Dave Bourque View Post
    Did you update the app? Did you try to do the motion it tells ya to do to clear the interference.

    Z10STL100-3/10.2.1.2141
    Yup.All of the above.
    I am beginning to really think it's a VZ issue with stl100-4 devices.
  20. Dave Bourque's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,391 Posts
    #20  

    Default

    Quote Originally Posted by jelp2 View Post
    Yup.All of the above.
    I am beginning to really think it's a VZ issue with stl100-4 devices.
    I've seen a lot of complaints about Verizon devices in these forums. So I wouldn't be surprised.

    Z10STL100-3/10.2.1.2141
  21. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #21  

    Default

    Quote Originally Posted by Dave Bourque View Post
    I've seen a lot of complaints about Verizon devices in these forums. So I wouldn't be surprised.

    Z10STL100-3/10.2.1.2141
    I just wish either VZ or BlackBerry would look into it. That's why I figured I'd try this thread in the VZ section. Maybe if there were enough people confirming it doesnt work there would be enough evidence for one of them to look into it.
    Last edited by jelp2; 04-14-2014 at 01:38 PM.
  22. Dave Bourque's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,391 Posts
    #22  

    Default

    Quote Originally Posted by jelp2 View Post
    I just wish either VZ or BlackBerry look into it. That's why I figured I'd try thus thread in the VZ section. Maybe if there were enough people confirming it does work there would be enough evidence for one of them to look into it.
    That's the problem. BlackBerry doesn't have the customer support resources. And when people call Verizon about their problems they most likely going to be like. " well let's get you on iPhone or Samsung".. lol the issue probably rarely hits BlackBerry offices because they are diverted to the carrier first.

    Z10STL100-3/10.2.1.2141
  23. Dave Bourque's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,391 Posts
    #23  

    Default

    My next suggestion would be to load another compass bar file.

    Z10STL100-3/10.2.1.2141
  24. iBuilder's Avatar
    CrackBerry Genius

    Posts
    4,671 Posts
    #24  

    Default

    Compass has never been accurate on my STL100-4. Furthermore, apps that use it don't match. Meaning Startracker will think east is north while the compass itself points due south.

    Posted via CB10
  25. jelp2's Avatar
    CrackBerry Addict

    Posts
    581 Posts
    Thread AuthorThread Author   #25  

    Default

    Quote Originally Posted by Dave Bourque View Post
    My next suggestion would be to load another compass bar file.

    Z10STL100-3/10.2.1.2141
    I've tried many bar files. The only one I haven't tried is the original one that came loaded on the phone. I don't remember the release OS and can't find any 10.0 downloads.
Page 1 of 4 1234 LastLast

Similar Threads

  1. Spotify login issue
    By Oscar Petlund in forum Android Apps (Amazon Store & APK Files)
    Replies: 3
    Last Post: 03-22-2014, 07:12 PM
  2. Moved from Z10 to Z30 Having Issues with Snap
    By walabe16 in forum BlackBerry Z30
    Replies: 10
    Last Post: 03-21-2014, 06:28 AM
  3. WiFi issues with 2228
    By kfehling in forum BlackBerry Z30
    Replies: 17
    Last Post: 03-21-2014, 12:34 AM
  4. Weird. Installed 2102 but still shows 1925
    By prplhze2000 in forum BlackBerry Z10
    Replies: 13
    Last Post: 03-20-2014, 08:01 PM
  5. Issues backing up videos, all I see is green
    By Runs_With_Scissors in forum BlackBerry Q10
    Replies: 5
    Last Post: 03-20-2014, 06:40 PM

Posting Permissions