1. edthedriver's Avatar
    I have searched High and low through alot of posts for the answers but to date have been unsuccessfull in finding an answer.

    I am trying to find a way to set the device to use Wifi instead of Mobile network while in a wifi area.

    The general response I have had and seen from the wifi board is to set the preferred connection to wifi, however I can't seem to find this option in any of the sub menus.. Can anyone give me a pointer in the right direction as I would love to have my wifi logo a nice shiny white!

    Any response much appreciated.
    05-22-09 06:31 AM
  2. fatboy97's Avatar
    If you look at http://forums.crackberry.com/f3/comp...ifi-how-47229/ on the second post you will see the following:

    Next, we will fine tune some other connection properties. Navigate to Home Screen > Manage Connections > Mobile Network Options. Under 'Connection Preference' make sure you have 'WiFi preferred' selected.

    This dictates what connection your device will choose, depending on availability. For example, if the WiFi is turned on and you enter one of your WiFi hotspots (which you added in Step 1) then your device will automatically connect and use that connection as the default connection (making UMA calls).
    (Please note, this does not automatically switch your browser configuration to connect between EDGE/WiFi. The WiFi preferred only affects the mobile network connection of your device. You will need to manually change from 'WiFi browser' to 'Internet' browser... and vise versa)

    You can change this setting to whatever you may desire... and the options are self-explanatory:
    • Mobile Network Only -- Will not use the WiFi connection to make any calls (browsing still available)
    • Mobile Network Preferred -- will only use WiFi when the Mobile Network is unavailable (in poor service areas)
    • WiFi Only -- Will only make UMA calls over WiFi, even if mobile network is available
    • WiFi Preferred -- will make UMA calls when a WiFi network is available, mobile network if not available
    Use the Manage Connections > Mobile Network Options. Under 'Connection Preference' make sure you have 'WiFi preferred' selected.

    Hope this helps.
    05-22-09 07:30 AM
  3. edthedriver's Avatar
    If you look at http://forums.crackberry.com/f3/comp...ifi-how-47229/ on the second post you will see the following:



    Use the Manage Connections > Mobile Network Options. Under 'Connection Preference' make sure you have 'WiFi preferred' selected.

    Hope this helps.
    Thanks for your reply, the problem I have is I can get to mobile network options, but within the sub menu I have no choice of how I wish to connect, I'm using O/S.199 and am now wondering if the issue is with this.. can anyone running .199 check there sub menus and see if you have the option to select 'WiFi Preferred'.

    Many thanks
    05-22-09 09:18 AM
  4. fatboy97's Avatar
    Thanks for your reply, the problem I have is I can get to mobile network options, but within the sub menu I have no choice of how I wish to connect, I'm using O/S.199 and am now wondering if the issue is with this.. can anyone running .199 check there sub menus and see if you have the option to select 'WiFi Preferred'.

    Many thanks
    I've had this option since .114 and every version I've upgraded to... although I've not used .199... I see no reason why they would have removed it for this one OS version and brought it back in .206... maybe it's time to upgrade to .206!!!
    05-22-09 09:40 AM
LINK TO POST COPIED TO CLIPBOARD