1. deltaiscain's Avatar
    I just got a BlackBerry Curve 8900 today, however, the WiFi doesn't seem to work. At home and at school. At home i have a password on my wifi, channel 11, b/g, i put it in, and it says error W002. I get the same error at school, and the school wifi doesn't have a password. My dad has the same blackberry, and his works perfectly. I looked up error W002, which is that the phone was unable to get an IP address from the DHCP server. Can anyone help?
    Thanks so much!!!
    Last edited by deltaiscain; 05-07-09 at 09:52 AM.
    05-07-09 09:50 AM
  2. lazerus's Avatar
    Try the obligatory battery pull.
    05-07-09 09:53 AM
  3. ClintRo's Avatar
    Try this thread first (after the battery pull)!!
    05-07-09 09:53 AM
  4. deltaiscain's Avatar
    Ok, i did a battery pull, however, it doesn't show a checkmark next to the connection, just a white line. it does have an IP address now, however, when i try to go to google, it says: "Unable to connect to the Internet, please try again later.
    If the problem persists please contact your service provider."

    and when i go to wifi diagnostics now, it says "IP address no longer valid."
    05-07-09 10:06 AM
  5. lazerus's Avatar
    Are you on the stock OS?

    I know it sounds silly, but perhaps an OS upgrade might un-fuch it.
    05-07-09 10:25 AM
  6. deltaiscain's Avatar
    Are you on the stock OS?

    I know it sounds silly, but perhaps an OS upgrade might un-fuch it.
    yes, stock os, and upgrading right now to latest beta. hope that fixes it.
    05-07-09 10:28 AM
  7. lazerus's Avatar
    Good luck, I'm sure you'll get it going. Wifi is pretty reliable on the 8900. Except for phone calls. For anyway, too many drop-offs....
    05-07-09 10:31 AM
  8. deltaiscain's Avatar
    Good luck, I'm sure you'll get it going. Wifi is pretty reliable on the 8900. Except for phone calls. For anyway, too many drop-offs....
    Managed to get it to work by changing some other settings too. Words cannot express my thank you.

    Thank you so unbelievably much!!! you guys are the best!!!
    I don't have a contract, so i need wifi.

    THANKS SO MUCH!!!!!!!!!!!!!
    05-07-09 10:44 AM
  9. John27's Avatar
    Managed to get it to work by changing some other settings too. Words cannot express my thank you.

    Thank you so unbelievably much!!! you guys are the best!!!
    I don't have a contract, so i need wifi.

    THANKS SO MUCH!!!!!!!!!!!!!
    How did you solve the problem? I have the same issue You only updated your software and it was fixed??
    05-19-09 02:59 PM
  10. GingerSnapsBack's Avatar
    How did you solve the problem? I have the same issue You only updated your software and it was fixed??
    I have the same problem to. I did a forum search and found this on a different phone thread. I've got the 8350i and just got a new one last night after my first 8350i is deceased. I even get this message using wifi.

    Edit -- try wiping your handheld. That worked for me.
    Last edited by ColdSunshine; 05-20-09 at 12:34 PM.
    05-20-09 08:09 AM
LINK TO POST COPIED TO CLIPBOARD
";