1. Texter's Avatar
    brand new curve. placing my SIM card in it now, but the silver door wont lock into place. WTF?
    11-19-08 04:43 PM
  2. johnmorganjr1's Avatar
    Mine is a booger too. I just took a small flathead and pushed on the clip while I pushed down on it. Worked like a charm....you might try that.
    11-19-08 04:59 PM
  3. bexx's Avatar
    I couldn't get my SIM card "door" to slide closed for anything when I first got mine. I just positioned it in there, put the battery in and I never had issues with it moving or falling out.
    After awhile, though, I tried again to get those metal prongs to slide and it did. Go figure! (Funny thing is now I can't get my Bold's latch OFF my SIM card now - I have bad luck).
    You can probably drop by a store and have them do it for you.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-19-08 05:14 PM
  4. dynalmadman's Avatar
    (Funny thing is now I can't get my Bold's latch OFF my SIM card now - I have bad luck).
    I don't think the Bold's SIM cover moves. I think you just lift gently on the free end of the SIM (just a LITTLE) and slide the SIM to the right. At least that has been the way I do it.

    Michael
    11-19-08 05:19 PM
  5. TheMilkyWay's Avatar
    Yes, I am very familar with that problem. Take it from me, relax and DON'T force it. Simply, lay it in there, pins lined up, and THEN read closely, under a light maybe, because it is hard to see which direction to slide it into the lock position.
    Good Luck. Relax and go by my instructions, I guarantee them or your money back!
    11-19-08 05:38 PM
  6. Texter's Avatar
    so if im right.... this is a COMMON issue then?.... good lol thought i was stuck here all alone!
    11-19-08 05:40 PM
  7. Texter's Avatar
    Yes, I am very familar with that problem. Take it from me, relax and DON'T force it. Simply, lay it in there, pins lined up, and THEN read closely, under a light maybe, because it is hard to see which direction to slide it into the lock position.
    Good Luck. Relax and go by my instructions, I guarantee them or your money back!
    i did. i slid it to the right where it says "lock" and still... no locking.
    11-19-08 05:41 PM
  8. TheMilkyWay's Avatar
    so if im right.... this is a COMMON issue then?.... good lol thought i was stuck here all alone!
    It's an ongoing issue with the CURVE. I have had several CURVES and most all of them, had the same issue. You really just have to be patient, look at the clip under good lighting to see which way to slide it to the lock position. Trust me, pull my finger.
    11-19-08 05:43 PM
  9. bexx's Avatar
    i did. i slid it to the right where it says "lock" and still... no locking.
    I'm guessing it is common enough. That's what mine did to me for ages, hence me giving up and just inserting the battery on top. Then one day the planets were aligned and I slid it over and it latched.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-19-08 05:46 PM
  10. TheMilkyWay's Avatar
    OK start all over. Back off a minute and collect yourself because I do know how frustrating it is. I broke many! After you take a deep breath go back in for the kill. Line up the pins properly and lightly slide the lock. Trust me a a really light sliding in the lock position and you will feel it under your finger when it catches. I wish I could do it for you but I can't so you have to relax, slow down, back off a minute and try again. You WILL get it.


    i did. i slid it to the right where it says "lock" and still... no locking.
    11-19-08 05:47 PM
  11. electric1#CB's Avatar
    Yeah, this was driving me crazy when I first got my curve. It turns out that I wasn't doing it the right way. I think inserting the sim was the only thing I've ever had to look up in the manual!
    11-19-08 08:37 PM
  12. Texter's Avatar
    actually, another question.................


    do you lay the sim flat, then put the latch over it? or you're supposed to fit the sim IN the silver latch, then close it down????

    seems like it doesnt fit in the silver latch (like the MicroSD would)
    11-19-08 09:15 PM
  13. leafs_fan's Avatar
    did you slide your sd card into the metal clip first? if you just set it in place and try to close, the little tabs on the clip won't let it lock.
    11-19-08 11:07 PM
  14. Texter's Avatar
    did you slide your sd card into the metal clip first? if you just set it in place and try to close, the little tabs on the clip won't let it lock.
    what? im tlaking about the SIM card.

    i know the microSD card slides into the metal piece, but im referring to the SIM.

    does the SIM slide into the metal piece, or u just place it down?
    11-20-08 04:51 AM
  15. TheMilkyWay's Avatar
    Slides in the thingy doo and then push it down easily. Take something rounded like a paper clip or the other size of a tweezer and look for the LOCK arrow and slide it into the lock postion OR go up to the local wireless store and have them do it for you and then don't take it out again!
    11-21-08 06:11 PM
  16. Navan's Avatar
    Mine has NEVER locked. Although if the SIM isn't in there it locks. When I bought it the rep said "it just doesn't work- don't worry, you shouldn't be fiddling with it anyways"...this is why I use leftalt, right shift, delete in instead of real battery pulls...SIM goes for a flying adventure every time.
    11-22-08 06:57 PM
  17. KingLV17's Avatar
    Relax and DON'T force it!
    11-22-08 07:48 PM
LINK TO POST COPIED TO CLIPBOARD