Results 1 to 8 of 8
  1. just_luc's Avatar

    Posts
    3,017 Posts
    Global Posts
    3,066 Global Posts
    PIN
    24BF22A0
    Thread AuthorThread Author   #1  

    Default Torch has no data service when connected to wifi

    Hi all,

    I'm currently travelling abroad, we have 2 blackberry's with and have turned mobile data off as we don't want to incur ridiculous charges.

    I've set up a wireless access point in my hotel room, my laptop and my 9700 (leaked OS6) connect to it fine, and can browse the internet, send and receive email, use bbm, facebook ect. So i know the access point is working and configured correctly.

    However, when we try and use the 9800, it says its connected to wifi, but will receive no messages and displays "unable to connect to the internet, please try again later" when trying to browse the internet.

    Any advice?


    RIM 950 .... Blackberry Z10 (STL100-3 on hybrid OS 10.3.0.140/misc) and everything in between
    + Playbook 32GB
  2. BBIsTheBest's Avatar
    CrackBerry Abuser

    Posts
    107 Posts
    PIN
    2320530D
    #2  

    Default

    I just tried that with my torch at home, and the same thing happened .
    as i figured out what u should do is to set connection preference to Wi-Fi only and turned the data services on.
    when u set it to wi fi only, mobile connection is automatically off, so no need to worry abt roaming data charges
  3. Stewartj1's Avatar
    CrackBerry Addict

    Posts
    930 Posts
    Global Posts
    939 Global Posts
    #3  

    Default

    Yep, if you turn data off you get no data on either transport.

    When you want to connect to wifi try turnoing data on and Mobile Network off. This will enable data over wifi but prevent using the cell carriers expensibve data service.

    I just tried this here at home and it worked - let us know if it works for you too.

    Posted from my CrackBerry at wapforums.crackberry.com
  4. storm_fan2009's Avatar
    CrackBerry Abuser

    Posts
    153 Posts
    PIN
    (PM me)
    #4  

    Default

    Quote Originally Posted by just_luc View Post
    Hi all,

    I'm currently travelling abroad, we have 2 blackberry's with and have turned mobile data off as we don't want to incur ridiculous charges.

    I've set up a wireless access point in my hotel room, my laptop and my 9700 (leaked OS6) connect to it fine, and can browse the internet, send and receive email, use bbm, facebook ect. So i know the access point is working and configured correctly.

    However, when we try and use the 9800, it says its connected to wifi, but will receive no messages and displays "unable to connect to the internet, please try again later" when trying to browse the internet.

    Any advice?
    As Stewart noted: connect to wifi, THEN turn off your mobile network. That should work just fine. It works on my 9800 anyplace I have wifi and don't want to use the mobile network. Best to you.
    ________________________________
    iPhone 4s 64GB and PlayBook 32GB Wi-Fi 2.0
  5. just_luc's Avatar

    Posts
    3,017 Posts
    Global Posts
    3,066 Global Posts
    PIN
    24BF22A0
    Thread AuthorThread Author   #5  

    Default

    hrmmm so I enabled data and turned off the mobile network.. this seemed to help, as its made a connection and I now have the browser working.. but still cannot access any bis services, ie bbm, or email.. facebook app displays error message that I am on a service plan that does not support this application and to call my carrier to subscribe..

    It would seem as though I need service books, but I can't download those over wifi can i?

    any more ideas?


    RIM 950 .... Blackberry Z10 (STL100-3 on hybrid OS 10.3.0.140/misc) and everything in between
    + Playbook 32GB
  6. kccman's Avatar
    CrackBerry Addict

    Posts
    568 Posts
    PIN
    24C92066
    #6  

    Default

    As I have used Wifi Data while in the States I have Mobile Network on, Data on, Data off when roaming checked, Wifi on....your good to go. BIS and browsing works using this method.
    10.2.0.228

    8330->9630->9530->9700->9800->9900 Black->9900 White->SGS3->Z10 Black(traded)Z10 White

    BBM Channel C00114265
  7. Stewartj1's Avatar
    CrackBerry Addict

    Posts
    930 Posts
    Global Posts
    939 Global Posts
    #7  

    Default

    BBM, IM, email and most web browsing will work fine over wifi only.

    Navigating to your BIS server or some other high security Blackberry servers will bypass your wifi transport and only work over a cell carriers data network.

    Posted from my CrackBerry at wapforums.crackberry.com
  8. Neekoo's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #8  

    Default No wifi when data is turned off.......

    I myself am having the same problem too. After reading a random post somewhere this might be it. If your having the same issue where the phone is connected to a wifi network but not able to utilize any of the functions / apps / browser, try turning on the data after you have established the wifi and your phone is showing your wifi network in service status menu. Once thats in place the phone will automatically use the wifi but when done you need to disable data again cause once there is nomore wifi detected then it will fall back to data and charges will apply. So I tried this and my phone and got bumped off wifi and I wasn't aware because I was on the phone downloading an all sorts of stuff so when I checked my cell bill right now it shows data charges from the time my phone lost the wifi connection. Im not sure if its all blackberry phones or torches but this is BS#@#$% for me when I don't have a data plan an this happens. Anyone know anything about keeping the phone on wifi without falling off? Maybe it has something to do with the router or both. I dont have this particular issue with my playbook it maintains a wifi connection.

    neko

Posting Permissions