1. delta_foxtrot2's Avatar
    Was out geocaching today with a 9500 (not 9530) where there was no network coverage and I lost GPS as well, I'm aware the CDMA version has been locked in the past but didn't think this was also occurring on the GSM versions.

    The same thing happens if you turn the radio off, GPS fails 99% of the time to get a lock.

    So is there a GPS bug in .83?

    I'm currently downgrading back to the vendor version .78 to see if the problem persists, if so I'll try wiping the phone completely and then if there is still an issue where's the best place to report it?
    12-25-08 07:47 AM
  2. delta_foxtrot2's Avatar
    vodafone .78 firmware seems to exhib the same "feature" as described above, and is easily reproducible by going out of coverage or disabling the radio, regardless if location aiding is enabled or not.

    Second thoughts it just too a long time to get a lock, but it's holding it, unlike .83 which failed to get a lock or hold it when it got a reading.
    Last edited by delta_foxtrot2; 12-25-08 at 08:29 AM.
    12-25-08 08:20 AM
  3. JRSCCivic98's Avatar
    GPS is in the same Qualcomm chipset as the radios. Disable one and you loose it all.
    12-25-08 10:37 AM
  4. delta_foxtrot2's Avatar
    GPS is in the same Qualcomm chipset as the radios. Disable one and you loose it all.
    That thought occurred to me initially but that doesn't explain going out of coverage and GPS going out too though, yet .78 release seems to be ok on this front.

    Also with .78, GPS works when you switch the radio off, so that can't be it either.
    Last edited by delta_foxtrot2; 12-25-08 at 11:30 AM.
    12-25-08 10:40 AM
  5. JRSCCivic98's Avatar
    .83 was not intended for the 9500 initially.
    12-25-08 11:41 AM
  6. delta_foxtrot2's Avatar
    .83 was not intended for the 9500 initially.
    Ahh that might explain it, in any case it works as I think it should with .78, so I hope this thread saves someone else from pondering
    12-25-08 12:45 PM
  7. Indecisive's Avatar
    blackberry maps was acting up for me on .83 the other day, it couldnt find me in the middle of the road.
    12-25-08 01:45 PM
  8. delta_foxtrot2's Avatar
    blackberry maps was acting up for me on .83 the other day, it couldnt find me in the middle of the road.
    On .83 TrekBuddy would jump between points going in and out of coverage, but the problem is at a lower level then the apps as best I can tell.
    12-25-08 01:52 PM
  9. delta_foxtrot2's Avatar
    After downgrading to .78 I noticed a bunch of bugs with it, like dropdowns in the browser not droping down, however as long as you have some kind of network coverage, even SOS only you have working GPS, no signal at all and no GPS.

    I'm going to upgrade back to .83 it has less bugs and video camera has a higher res.
    12-26-08 04:11 AM
LINK TO POST COPIED TO CLIPBOARD
";