Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 4 1234 LastLast
Results 1 to 25 of 91
Like Tree15Likes
  1. svelt's Avatar
    CrackBerry Addict

    Posts
    557 Posts
    Global Posts
    564 Global Posts
    Thread AuthorThread Author   #1  

    Lightbulb [Solved] Warning: Do not install any new os or update if you plan on using google maps

    I might as well have just thrown away my phone now two months prior to BB10 even being launched because Google Maps has crapped out as I installed a new hybrid OS on my phone. INSTALLING OR UPDATING TO A NEW OS WILL RE-INSTALL GOOGLE MAPS, WHICH WILL NO LONGER WORK. Google Maps will display a "serious error" when loading and crash.

    This NEEDS to be on the front page news on CrackBerry.com. Google Maps is one of my most used apps on my Blackberry - exceedingly reliable and invaluable for travelling anywhere and finding anything. BB Maps doesn't come close. I'm already scouring Craigslist for any un-wiped BB or even an Android device to get the app back for at least until a few months before I can get BB10. All because this information was not made available anywhere except buried in this thread on the 9900 forum:

    Google maps not available for blackberry

    Hopefully a miracle will occur and someone can find a workaround, or persuade Google to let legacy devices use their services. Otherwise we're all SOL.

    Edit - There is a workaround!
    http://forums.crackberry.com/general...new-os-757894/
    Last edited by BigBadWulf; 12-14-2012 at 07:41 PM. Reason: added workaround
    Thanked by 2:
    Bold_until_Hybrid_Comes (12-13-2012),  PiotrJot (12-14-2012) 
  2. BBThemes's Avatar
    CrackBerry Genius of Geniuses

    Posts
    5,369 Posts
    #2  

    Default

    are you sure it is not in any way related to the hybrid OS you are using?

    Thorsten said ZED 10. deal with it
    My Apps in BlackBerry World
    My Platinum 9900


    For all my themes - BBThemes.co.uk and follow me on @BBThemes1
  3. lnichols's Avatar
    CrackBerry Genius of Geniuses

    Posts
    6,811 Posts
    Global Posts
    7,349 Global Posts
    #3  

    Default

    Have you tried locating the JAD file for the version that did work? I've found Google Maps to be iffy on how it works from version to version. I have 4.5.3 on my Bold and it works find so you may want to look for that version. The issue isn't phone, Google is just being asses. And if you buy another BlackBerry phone without Google Maps you will hit this same issue.
  4. bmercer94's Avatar
    CrackBerry Master

    Posts
    1,033 Posts
    Global Posts
    1,035 Global Posts
    #4  

    Default

    @BBThemes we're sure, i loaded official to test, it still happens. Google has blocked new activations of GMaps from BB devices. if you had it installed already, it still works.

    @Above i've got the .jad/cod files for 4.5.3, still google's fault.
    Device(s): Curve 9300>Bold 9700>Z10>Samsung Galaxy Note 2>Z10 #BlackBerryByChoice
    Tablet: BlackBerry Playbook 32GB
  5. svelt's Avatar
    CrackBerry Addict

    Posts
    557 Posts
    Global Posts
    564 Global Posts
    Thread AuthorThread Author   #5  

    Default

    It's not the Hybrid as mentioned above. Google has broken it. No one's fault but theirs, but please make this front page news CB staff. This needs more attention paid to it as to some people who rely on the app, updating their OS will essentially be the same as bricking their phone.
  6. lnichols's Avatar
    CrackBerry Genius of Geniuses

    Posts
    6,811 Posts
    Global Posts
    7,349 Global Posts
    #6  

    Default

    Quote Originally Posted by bmercer94 View Post
    @BBThemes we're sure, i loaded official to test, it still happens. Google has blocked new activations of GMaps from BB devices. if you had it installed already, it still works.

    @Above i've got the .jad/cod files for 4.5.3, still google's fault.
    So there is an activation that occurs when the app is installed? Interesting. I wonder why Google is doing this? Is it just to snub a competitor, or do they fear BB10 and want to try to get people to dump BlackBerry devices before BB10 is available? Really worried for the future of the Internet. Will Google eventually not allow you to access their services without an Android phone or without being a customer of their Google Fiber offering?
  7. bmercer94's Avatar
    CrackBerry Master

    Posts
    1,033 Posts
    Global Posts
    1,035 Global Posts
    #7  

    Default

    The Terms of service shows up, but you get an error.



    I believe BB10 actually plays a part in it. they don't want people to jump ship from Android, as they will lose money.
    Device(s): Curve 9300>Bold 9700>Z10>Samsung Galaxy Note 2>Z10 #BlackBerryByChoice
    Tablet: BlackBerry Playbook 32GB
  8. travaz's Avatar
    CrackBerry Addict

    Posts
    971 Posts
    Global Posts
    1,022 Global Posts
    PIN
    I have three
    #8  

    Default

    In my opinion I think you are going to see more and more of this kind of thing as different platforms are going to shut out other OS in the name of forcing you to chose what you want. If you cant live without Google maps than you may have to go to Android. I can see MS doing this also. The only way you can get BBM is on a Blackberry device.
    Hgouck likes this.
  9. BB_Bmore's Avatar
    CrackBerry Genius

    Posts
    3,844 Posts
    Global Posts
    3,860 Global Posts
    PIN
    excepting applications
    #9  

    Default

    Wow Im ready to dump Google all together this is a slap in the face! Yet they build maps for ios? Makes no sense to me.
    I waited...It launched...Im still waiting...
  10. BB_Bmore's Avatar
    CrackBerry Genius

    Posts
    3,844 Posts
    Global Posts
    3,860 Global Posts
    PIN
    excepting applications
    #10  

    Default

    Id love to hear what Google has to say about this issue lol
    I waited...It launched...Im still waiting...
  11. svelt's Avatar
    CrackBerry Addict

    Posts
    557 Posts
    Global Posts
    564 Global Posts
    Thread AuthorThread Author   #11  

    Default

    I've already sent them an inquiry. I'd encourage everyone who cares about having GMaps on their device to do the same. See if it's a temporary bug or an intentional move. Going to Google Mobile on my BB still allows me to download the maps, so they are still officially hosting it for Blackberry which is strange if they've decided to break functionality of new installations...
  12. sam_b77's Avatar
    CrackBerry Genius

    Posts
    2,734 Posts
    Global Posts
    2,739 Global Posts
    #12  

    Default

    I can confirm what the OP said. I had updated my OS yesterday. On seeing this thread, i tried to start Google Maps and got the serious error message.
    Google sucks.....
    Through the Years :2001 Ericsson T29s> Sony Z5> Sony Z7> SE Z600>Moto A760> RAZR V3>Razr V3i>BB 8800>BB 9500 >BB 9800>Bold 9900..RIM Returns with a bang

    Life was much simpler when Apple and Blackberry were just fruits
  13. diffused's Avatar
    CrackBerry Abuser

    Posts
    463 Posts
    #13  

    Default

    Thereis a workaround link in these forums. I used it two days ago and it's works as good as before.
    ~diffused

    Z10
    OS 10.2.1.2122
    Verizon
  14. Hgouck's Avatar
    CrackBerry Master

    Posts
    1,099 Posts
    Global Posts
    1,173 Global Posts
    #14  

    Default

    Google maps, while good, is not the only or even the best option for navigation. IMO. But if it is important for you to use Google maps I would select a different device. More and more we will see lock outs of specific apps.
    Here is a link for the the work around thread http://forums.crackberry.com/blackbe...kberry-757767/
    I hope this helps.
  15. Bold_until_Hybrid_Comes's Avatar
    Waterloo's Finest

    Posts
    5,431 Posts
    Global Posts
    5,460 Global Posts
    #15  

    Default

    Well im screwed. Im in europe and i updated to the latest 7.1 build (whatever its at now) OTA from vodafone a few weeks ago. Everything works good except my camera doesnt work. So i have to reinstall the OS when i get home. But now i read this. I have to choose between a camera and google maps.
    Phones: Nokia 5110>Nokia 3360>Siemens C56>Moto RAZR>LG Chocolate>Pearl 8100>Bold 9000 >Pearl 9100 + Bold 9900 > iPhone 4S + Z10 + Bold 9000
    Tablets: 16GB Playbook > Playbook 32GB
    __________________________________________________ _________________________

    CLICK HERE TO JOIN THE SEXY GIRLS IN YOGA PANTS CHANNEL

    C000288CC
    __________________________________________________ ___________________________
  16. svelt's Avatar
    CrackBerry Addict

    Posts
    557 Posts
    Global Posts
    564 Global Posts
    Thread AuthorThread Author   #16  

    Default

    Quote Originally Posted by diffused View Post
    Thereis a workaround link in these forums. I used it two days ago and it's works as good as before.
    I believe it has stopped working as of...today or yesterday?
  17. Phill_UK's Avatar
    CrackBerry Wiseguy

    Posts
    12,709 Posts
    Global Posts
    12,725 Global Posts
    #17  

    Default

    Quote Originally Posted by diffused View Post
    Thereis a workaround link in these forums. I used it two days ago and it's works as good as before.
    There is no workaround... you can still install the app, but you can no longer accept the T&C so it won't work.
    That's Phill with 2 L's
  18. Bold_until_Hybrid_Comes's Avatar
    Waterloo's Finest

    Posts
    5,431 Posts
    Global Posts
    5,460 Global Posts
    #18  

    Default

    Wasnt the work around a different way to download it, not get by the T &C? I forget
    Phones: Nokia 5110>Nokia 3360>Siemens C56>Moto RAZR>LG Chocolate>Pearl 8100>Bold 9000 >Pearl 9100 + Bold 9900 > iPhone 4S + Z10 + Bold 9000
    Tablets: 16GB Playbook > Playbook 32GB
    __________________________________________________ _________________________

    CLICK HERE TO JOIN THE SEXY GIRLS IN YOGA PANTS CHANNEL

    C000288CC
    __________________________________________________ ___________________________
  19. #19  

    Default

    What's the timeline for this issue? On 9-Dec I wiped my device, installed an hybrid, restored Google maps with my other 3rd party apps from my BBSak back-up and it's working just fine. (Actually better, since my GPS lock is the best I've experienced.)
  20. Phill_UK's Avatar
    CrackBerry Wiseguy

    Posts
    12,709 Posts
    Global Posts
    12,725 Global Posts
    #20  

    Default

    Quote Originally Posted by Bold_until_Hybrid_Comes View Post
    Wasnt the work around a different way to download it, not get by the T &C? I forget
    It doesn't matter how you download or install it, you still have to accept the T&C before you can use it... and for the past couple of days this has not been possible.
    That's Phill with 2 L's
  21. TheScionicMan's Avatar
    CrackBerry Genius of Geniuses

    Posts
    8,977 Posts
    #21  

    Default

    Could this possibly be an error of some sort that needs to be fixed? It doesn't make sense to exclude a small phone segment while putting out an app for another one. They do have errors upon occasion, just like GMail, etc. this week. I'll wait to hear more before removing and cursing all things Google. I hardly use it since I got BB traffic anyway.

    As far as getting a reply to inquiries, good luck. They barely even reply to PAYING customers when services go down.
    Shiva Kamini Somakandarkram !!!!!!!!!!!!!
  22. Bold_until_Hybrid_Comes's Avatar
    Waterloo's Finest

    Posts
    5,431 Posts
    Global Posts
    5,460 Global Posts
    #22  

    Default

    Quote Originally Posted by Phill_UK View Post
    It doesn't matter how you download or install it, you still have to accept the T&C before you can use it... and for the past couple of days this has not been possible.
    Thats what im saying. It wasnt really a work around
    Phones: Nokia 5110>Nokia 3360>Siemens C56>Moto RAZR>LG Chocolate>Pearl 8100>Bold 9000 >Pearl 9100 + Bold 9900 > iPhone 4S + Z10 + Bold 9000
    Tablets: 16GB Playbook > Playbook 32GB
    __________________________________________________ _________________________

    CLICK HERE TO JOIN THE SEXY GIRLS IN YOGA PANTS CHANNEL

    C000288CC
    __________________________________________________ ___________________________
  23. DenverRalphy's Avatar
    CrackBerry Genius

    Posts
    3,373 Posts
    Global Posts
    3,951 Global Posts
    PIN
    Temporarily sans BB
    #23  

    Default

    I'd speculate it's an unintended error and not a conscious act to halt support on Blackberry. If Google had decided to block BB's from working, you'd get a "Device/Platform not supported" message, not a fatal error.
  24. diffused's Avatar
    CrackBerry Abuser

    Posts
    463 Posts
    #24  
    Thanked by:
    Bold_until_Hybrid_Comes (12-13-2012) 
  25. Phill_UK's Avatar
    CrackBerry Wiseguy

    Posts
    12,709 Posts
    Global Posts
    12,725 Global Posts
    #25  

    Default

    We don't need an external download link. Google Maps can still be installed directly from Google... http://dl.google.com/dl/mobile/maps/...GoogleMaps.jad
    The problem is that for the last couple of days you cannot accept the terms and conditions when the app is started for the first time, so it won't work.
    For that, at present, there is NO workaround.
    That's Phill with 2 L's
Page 1 of 4 1234 LastLast

Similar Threads

  1. Do not install [ANY] Android App
    By varunsain in forum PlayBook Apps & Games
    Replies: 128
    Last Post: 01-05-2014, 02:43 PM
  2. It's official: OS .282 is crap. Do not install this!
    By bmwmpower in forum BlackBerry Bold 9000
    Replies: 70
    Last Post: 07-19-2009, 02:37 AM
  3. Any tips on installing the new OS?
    By mzdrati in forum Storm OS Discussion
    Replies: 10
    Last Post: 05-30-2009, 08:15 PM
  4. DM does not upgrade Storm to any new OS.
    By Stormer1122 in forum Storm OS Discussion
    Replies: 35
    Last Post: 04-28-2009, 10:18 PM
  5. WARNING: DO NOT PURCHASE MP3s from Yahoo! Music for ANY Blackberry
    By mdattorney in forum General BlackBerry Discussion
    Replies: 32
    Last Post: 11-30-2008, 05:43 PM

Posting Permissions