1. ress's Avatar
    As a proud new owner of a BB 8120 with WIFI I'm stunned to read about WIFI difficulties posted here.

    I don't have a data plan or BES and planned on using WIFI only.

    Now I'm concerned that may be there is no way of globally configuring the device to use WIFI only and not to download data via my carrier's network. Or is there?

    I want to be able to accept regular phone calls while connected to WIFI. Is this possible?

    Is there a way to delete or alter the carrier's service books to disable data transfer via their network?

    How can I see when a connection is being done via WIFI and when it's happening via the carrier?
    09-15-08 11:42 AM
  2. oakie's Avatar
    open up your browser options and go to general properties > default browser and set it to "hotspot browser" or "wi-fi browser" depending on the options you're given. it will be one or the other. this will ensure that whenever you open the browser, it will only try to access a wifi network and will not work on a regular edge connection.

    then go to options > mobile network and set connection preference to "wifi preferred".

    other than that, there is no way to "idiotproof" the device by completely locking out data other than to use mobile network options to completely turn off data. data usage is integral to the blackberry experience, and generally if a blackberry data package is not an option for the customer, it is highly suggested they choose a different device.

    as for how to ensure you're on wifi only, choose "manage connections" and uncheck "mobile network"... it turns off the cellular radio and if you're connected via wifi, your data will be obviously over the wifi network only.
    09-16-08 05:50 AM
  3. ress's Avatar
    Thanks for the reply.

    Actually the reason I bought the Blackberry was because it had WIFI. The fact that you can switch to an edge connection when you're out of WIFI's reach is nothing more than an expensive extra!

    Turning off the radio seems to turn off the telephone. True? I want to have both WIFI and receive phone calls.

    I've set my browser to HOTSPOT browser.

    BUT... when I select OPTIONS - MOBILE NETWORK, I only have a choice of carriers. There is no WIFI setting included in the list.

    In other words, I can't figure out how to select WIFI preferred!

    Is something wrong? I have BBOS version 4.5.

    Am I still using the carrier's edge connection or my free home and office WIFI?

    One is obscenely expensive while WIFI is free.
    09-16-08 05:34 PM
  4. Reed McLay's Avatar
    Welcome to CrackBerry.

    I was in a similar situation last year. The cost of carrier data service was too high to justify. I bought a 8320 and have been using it Wifi only for the past 9 months.

    None of the communications features work with a stand alone Wifi device. The work around is to use web based communications. Google does a fine job of supporting mobile Wifi with iGoogle and Gmail.

    The situation changed when my carrier dropped their data charges from $10 Mb to $0.005 Mb, thanks to competition from Apple. Then they sealed the deal with UMA and unlimited National calling.

    Now, I can use all the communications features through Wifi instead of my nearly non-existant EDGE signal. One bar, on a good day, for a while.

    Setting it up with Wifi is a little tricky. There are a couple dependencies located in different places.

    Options / Mobile Network: Data service must be ON. Connection preferencs should be set to WiFi Only.

    (tip: Highlight the second line down. Press Menu and select Change Option.)

    Browse / Options / Browser Configuration: Hotspot Browser should now be available.
    Last edited by Reed McLay; 09-17-08 at 03:10 PM.
    09-17-08 03:06 PM
  5. ress's Avatar
    Reed, thanks.

    One question, though:

    I can't find "CONNECTION PREFERENCES." I often get the feeling that my OS 4.5 is missing menu items.

    If I go to OPTIONS - MOBILE NETWORK, I have only the following choices:

    1) Data Services (ON)
    2) Mobile Network
    3) Network Selection Mode (Manual)
    4) Select Automatic Mode (Prompt)

    If I highlight any of these lines, I always get the following choices:

    1) Help
    2) Coopy
    3) Diagnostics Test
    4) Add to Preferred
    5) My Preferred Network
    6) Switch Application
    7) Close

    Browser is set to Hotspot Browser. I can now use Internet with these settings.

    HOWEVER, the WIFI connection has a yellow indicator instead of a green one. Is this still okay?
    09-17-08 04:33 PM
LINK TO POST COPIED TO CLIPBOARD
";