1. 12MaNy's Avatar
    Hi there. I have a "Guinea Pig" Curve and I'm trying to downgrade my OS back to 4.3 from 4.5. I'm doing this because I'm trying to install the newest 4.5 on Blackberry.com's device software page and I think I might have a better chance if I downgrade back to 4.3. However, I am encountering some issues and I need some help.

    I downloaded OS version 4.3.0.127 from Blackberry.com and installed it on my PC. I then wiped my device and plugged it in via USB. The DM wouldn't recognize my device, so I deleted the vendor XML file and it still wont recognize my device. I then decided to just delete the device software and start over. After deleting the device software the DM STILL won't recognize my device!

    Anyone have any advice that could possibly help me out? - Thanks
    09-26-08 11:48 AM
  2. jeffh's Avatar
    First, it wasn't necessary to roll back. Too late this time, but you'll know for the next time. Second, start over and follow the Upgrade / Downgrade Procedure that's linked in my sig. It has steps to deal with the scenario you are describing.
    09-26-08 12:10 PM
  3. Reed McLay's Avatar
    A lot of 8330 users have noted this problem.

    The install of the device OS has corrupted your USB drivers. The solution is simple, reinstall BlackBerry Desktop Manager. That will correct the problem.

    I have been experimenting with the automatic update too. If I understand what I am seeing, it uses your PIN number to identify your carrier and locate the correct OS verison.

    In that case, you will still get v4.3xx.
    09-26-08 12:16 PM
  4. 12MaNy's Avatar
    First, it wasn't necessary to roll back. Too late this time, but you'll know for the next time.....
    Actually, it is necessary because this "official" version of 4.5 that their offering might be be a downgrade to what's already installed on my "Guinea Pig" device.



    A lot of 8330 users have noted this problem.

    The install of the device OS has corrupted your USB drivers. The solution is simple, reinstall BlackBerry Desktop Manager. That will correct the problem.

    I have been experimenting with the automatic update too. If I understand what I am seeing, it uses your PIN number to identify your carrier and locate the correct OS verison.

    In that case, you will still get v4.3xx.
    Thanks. I've been experimenting with this "new version of 4.5" since yesterday with no results. I think I'll just give up and wait until I hear something. Lol
    09-26-08 12:45 PM
LINK TO POST COPIED TO CLIPBOARD