1. zackberry's Avatar
    hi everyone, im new to the site, and just got a new blackberry bold. i previously had a pearl (8100) and absolutly loved it and am extremly happy so far with this new amazing device. unfortunatly, i have found a few issues with my paticular device.
    first off, let me say i subscribe to Rogers. I have no actual Blackberry data plan though (will soon be getting Blackberry $45 messaing plan).
    When i setup wifi, i search for my network, it finds it, yada yada...but under Manage Connections, Wi-Fi "Home" has a white dash next to it, as opposed to a check mark as it should. ive tried connecting to 2 other networks and the same thing happens. wifi is on though. the wifi sign in the corner is on, but kind of dark (which i believe means it is not connected, however it says it is under connection properties.). I am completely stumped! could it be that I must register my device or something or activate Wi-Fi with Rogers?? also, I have no GPS or Maps icon anywehre which means I cannot use it! another thing im stumped on! a friend recently got the bold, and has had none of these problems, but does have the 500mb data plan, so perhaps I need a data plan?? also, i have no weather or stocks icon anywehre!
    please help! i am very upset that my bold has issues! thanks and merry christmas and happy holidays
    12-24-08 09:59 PM
  2. sunkast's Avatar
    12-24-08 10:15 PM
  3. FuX's Avatar
    hmm, your wifi problem could be a number of things.. security on your router for one, eg. pass keys and filtering check em out..

    GPS is found under options, advanced options, GPS.. the Maps icon might be hidden or not installed.. check under advanced options, Applications.
    You could also download the latest OS\firmware for your Bold from your provider or put on a leaked firmware which should bring back Maps if you select it during the update.

    Im pretty sure weather and stocks isnt a stock program from RIM you will need to download these apps yourself.
    12-24-08 10:19 PM
  4. Bla1ze's Avatar
    I have no actual Blackberry data plan
    There is your issue for the most part, you need an active data plan to even get the service books pushed to your device.

    WiFi alone will NOT push RIM service books, you can create a BIS accnt and try..but I'm sure they will never show up.
    Good way to check this is to go to Options/Advanced Options/Service Book and see if you have the WiFi TCP/IP Browser as well as the WiFi TCP/IP Transport Service books.

    please help! i am very upset that my bold has issues! thanks and merry christmas and happy holidays
    Your device is not the issue...your rogers accnt, however is. Get a data plan ASAP and all your problems will disappear.

    Im pretty sure weather and stocks isn't a stock program from RIM you will need to download these apps yourself.
    These are service books pushed to your device upon device activation with a data plan and yes, they are indeed stock on the Bold.
    12-24-08 10:24 PM
  5. romeo204's Avatar
    just remember a data plan is the blood of your BB and without one you won't have the true BB experience .
    12-24-08 10:40 PM
  6. lilbea's Avatar
    Just do this!!!!
    1Go to manage connection
    2Turn mobile network and wifi on
    3turn bluetooth off
    4Go to mobile network options
    5make sure data services is on
    6go to options
    7choose advanced options
    8make sure default browser configuration is hotspot browser
    9connect to your wi fi
    and enjoy
    12-25-08 12:11 AM
  7. cobra302's Avatar
    hi everyone, im new to the site, and just got a new blackberry bold. i previously had a pearl (8100) and absolutly loved it and am extremly happy so far with this new amazing device. unfortunatly, i have found a few issues with my paticular device.
    first off, let me say i subscribe to Rogers. I have no actual Blackberry data plan though (will soon be getting Blackberry $45 messaing plan).
    When i setup wifi, i search for my network, it finds it, yada yada...but under Manage Connections, Wi-Fi "Home" has a white dash next to it, as opposed to a check mark as it should. ive tried connecting to 2 other networks and the same thing happens. wifi is on though. the wifi sign in the corner is on, but kind of dark (which i believe means it is not connected, however it says it is under connection properties.). I am completely stumped! could it be that I must register my device or something or activate Wi-Fi with Rogers?? also, I have no GPS or Maps icon anywehre which means I cannot use it! another thing im stumped on! a friend recently got the bold, and has had none of these problems, but does have the 500mb data plan, so perhaps I need a data plan?? also, i have no weather or stocks icon anywehre!
    please help! i am very upset that my bold has issues! thanks and merry christmas and happy holidays
    seems like the wifi is hit and miss at times. my bold will connect to wifi at work just fine. but at home i just cant get on. it will stay on then off, on then off over and over. everything i've found says that it may have something to do with the bold not liking particular models or brands of router. i'm using a netgear and it just wont work right. the linksys at work though works just fine. good luck.
    12-25-08 12:14 AM
  8. boby6's Avatar
    I have the exact same problems as you and also just recently purchased my bold. Configure the wifi network you want and you should see the name of it above the rogers name in the home screen, than go to manage connections>set up wifi network>wifi hotspot login, that is how u use the wifi. It is not through the browser as you may have thought.
    12-25-08 12:36 AM
  9. lilbea's Avatar
    Well i called my service provider and they said in order to use blackberry bold wifi you NEED a data plan
    Also my bold is missing maps
    Last edited by lilbea; 12-25-08 at 12:51 AM.
    12-25-08 12:42 AM
  10. MiaBlackStang's Avatar
    Just do this!!!!
    1Go to manage connection
    2Turn mobile network and wifi on
    3turn bluetooth off
    4Go to mobile network options
    5make sure data services is on
    6go to options
    7choose advanced options
    8make sure default browser configuration is hotspot browser
    9connect to your wi fi
    and enjoy
    Worked like a charm!!! Thanks...
    12-25-08 08:10 AM
  11. AStranger's Avatar
    Well i called my service provider and they said in order to use blackberry bold wifi you NEED a data plan
    Also my bold is missing maps
    Either the service person is wrong or it's a crying shame they would allow this kind of requirement.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-25-08 10:56 AM
  12. funk18's Avatar
    Well i called my service provider and they said in order to use blackberry bold wifi you NEED a data plan
    Also my bold is missing maps
    when i got my bold i had the same problem because i only have the emailing plan...and i talked to the bb rep at the rogers store and he told me you NEED the data plan to use WIFI.....THIS IS BULL****!
    go to options, the advanced options, then browser and the make sure your default browser configuration is Hotspot Browser and not Rogers Mall.

    this instantly fixed my wifi problem.

    as for maps/gps i can't seem to get passed to no data problem. has anyone been able to use any gps/map app with the email plan only???
    12-29-08 10:36 AM
  13. Iya's Avatar
    Funk,

    I just got a used Bold, no sim card, OS 168 and I can use wifi and surf the net.
    Maybe Rogers locks you thru the OS ??
    01-12-09 04:58 PM
LINK TO POST COPIED TO CLIPBOARD
";